Motor PWM too high when safety switch is pressed

I’m running AC3.1.5 on a Pixhawk.

I’ve encountered a couple problems with the PWM output range for the ESCs.

Prior to pressing the safety button, the controller doesn’t output any PWM signal by default. This is OK, although slightly annoying since the ESCs beep a lot because of it. I can add “pwm disarmed -c 1234 -p 900
” to the startup file to prevent this.

The big problem is that I immediately get a 1.171ms PWM output when I enable the safety switch. This is prior to actually arming using the transmitter. This is in the range where my 30A Opto ESCs will spin the motors.

When I’ve set the disarmed PWM, they will start to spin while I still have my hand on the button and cannot be stopped until the button is pressed again. With the default behavior (no PWM when disarmed), the ESCs will not accept the 1.171ms PWM without getting a shorter PWM first and beep quickly.

I’ve tried adjusting THR_MIN, but it doesn’t seem to have any effect. What parameter do I need to change to get a lower PWM output?

Solved. The throttle PWM has to be adjusted to the correct range on the transmitter before doing calibration.