Servers by jDrones

Motor out (ch1-4) pwm issues

So i have a pixhawk cube 2 running 3.4FW, we are experiencing issues with sudden loss of altitude and have discovered from our logs that our PWM motor out (ch1-4) are not fully syncd together, even in a bench test is acro mode. 2 motors go up to 2000 and the other 2 max at 1400-1500. we have calibrated 4 in 1 esc as well calibrated the tx/rx, and verified that all rc in go to 2000. we are trying to find out if we have a faulty Pixhawk. Thanks for any troubleshooting this. I have attached the screenshot of our log for reference.
[log file]
(https://drive.google.com/open?id=1TAMPLEoShLoKjr8OhHQueqVrizI0P9Fq)

The most obvious question first - is the drone balanced around the centre ?
It seems your right side is not performing well or is heavier.
You say a Cube 2, do you mean a Cube 2.1, as the Cube 2 was only used in the Solo?

These issues are are generally mechanical in nature.
Your desired v actual indicates the controller is trying but not able to pull things into line.
Have you tried taking off and flying in Stabilise mode?
You are running older firmware, have you tried upgrading?

Servers by jDrones