Motor oscillation 50% throttle Octacopter

Hi! I recently mounted an Octacopter X4 and I have a problem when I keep the drone on the ground but with throttle in 50% the frame suffers torsion due to the oscillation of the motors due to the format, I leave a video below with the demonstration of the problem:

When exceed 50% of throttle the oscillation disappears and the drone fly normally, the problem only appears with the drone on the ground. I think that increasing or decreasing the motors speed when the throttle is at 50% solves the problem, but I want to change the parameter for when the equipment is on the ground, I don’t know if this is possible. I’m afraid of changing the parameter and influencing the flight.

We call that a Quad X8 or Octoquad.
Put the .bin log file up on a file hosting site like onedrive or dropbox and post a link here.
I’ve got a fair idea of what to do, but better to see the log file first.

@xfacta Follow the link to download the file. https://drive.google.com/file/d/1keAq2BRk7H2m70naEPoOnyNwMt3WWC48/view?usp=sharing

If this only happens on the ground then you should be fine. It is most likely a resonance issue with the landing gear.

1 Like

Try changing the MOT_SPIN_ARM parameter perhaps the frame/landing gear won’t be excited at a different RPM. Yours isn’t the 1st X8 that has exhibited this.

@manavgandhi17 The problem only happens when the drone is on the ground.

@manavgandhi17 I only need to adjust the speed of the engines with the throttle at 50% and I only have one option that would be to increase the speed of the engines in the arm.
I don’t think slowing down is an option as the drone can turn off the engines in flight when it’s reducing Throttle.
Does increasing the speed of the arm run the risk the drone not being able to land? Or even take off when get the throttle at 50%?

You are confusing MOT_SPIN_MIN with MOT_SPIN_ARM. You could set MOT_SPIN_ARM to 0 w/o any effect on flight. Some people do as they don’t like props spinning upon arming.

@dkemxr I have a doubt, currently when I arm the engines they have a rotation and when I put the throttle in 50% the acceleration increases, it is possible to identify this in the video.

If set the MOT_SPIN_ARM up to a rotation that doesn’t cause this wobble, when set the throttle to 50% it will probably increase as well.

I have to do a test and increase it little by little to find the correct value so that the oscillation disappears and that it doesn’t take off with the throttle at 50%.

Or decrease it. I usually set MOT_SPIN_ARM to the lowest all the motors will turn smoothly. Again it has nothing to do with flight thrust.

Or, you could simply ignore the oscillation on the ground and fly the craft…

@dkemxr My value is already low, if I’m not mistaken 2% more than MOT_SPIN_MIN, I’m thinking that decreasing 5 or 6% will enter the dead zone of one of the escs.

Would not like to keep this wobble.

Set these and retest
ATC_RAT_YAW_P,0.8
ATC_RAT_YAW_I,0.08
INS_LOG_BAT_MASK,1

Also set these
INS_ACCEL_FILTER,20
BATT_ARM_VOLT,22.10
BATT_CRT_VOLT,21.00
BATT_LOW_VOLT,21.60
BATT_FS_CRT_ACT,1
BATT_FS_LOW_ACT,2

If you get airborne OK just hover and do some gentle movements in ALTHOLD mode and then post that log

@xfacta Ok, I’ll do the tests and post the result.

@xfacta I did the test in althold mode, noticed by the landing gear that the machine started to vibrate in the video think it is not possible to see.

The oscillation also continued.

https://drive.google.com/file/d/1keAq2BRk7H2m70naEPoOnyNwMt3WWC48/view?usp=sharing

You didnt change any of the parameters I asked you to and the issue is still the same

Sorry, I shared the old log link.

This is the correct:

https://drive.google.com/file/d/1F4ddIbrce5NH2J5YEk4xc7zmxm3aph0Z/view?usp=sharing

no access to the log

Use the MissionPlanner motor test to check what percentage those motors and props need to reliably start up. If for example it’s 10, then set MOT_SPIN_ARM to 0.10
Get MOT_SPIN_ARM as low as possible but still reliable. As Dave mentioned this doesn’t change any flight characteristics or affect thrust.

Then set MOT_SPIN_MIN to MOT_SPIN_ARM + 0.03 , for example MOT_SPIN_MIN,0.13

You can see the yaw oscillations clearly in this new log
I included a couple of motor outputs there to show the full effect

Next try these even lower
ATC_RAT_YAW_P,0.6
ATC_RAT_YAW_I,0.06
Does it look like the yaw oscillations get worse or better?

Next step is to increase this
ATC_RAT_YAW_D,0.005

If everything is getting worse instead of better, you could increase these
ATC_RAT_YAW_P,2.0
ATC_RAT_YAW_I,0.2

The FFT is a bit of a mess at the moment due to yaw oscillations, but I think you can safely put these in place, and we might have to adjust them a little after the next test flights.
INS_HNTCH_ENABLE,1 ← set this then refresh params to see the rest
INS_HNTCH_MODE,1
INS_HNTCH_REF,0.30
INS_HNTCH_FREQ,50
INS_HNTCH_BW, 25
INS_HNTCH_ATT,40
INS_LOG_BAT_OPT,2
Definitely set the HNOTCH parameters before the next test flight.

These might improve pitch and roll a bit before running the next Autotune. These should be safe values.
ATC_RAT_RLL_P,0.1
ATC_RAT_RLL_I,0.1
ATC_RAT_RLL_D,0.00625
ATC_RAT_PIT_P,0.1
ATC_RAT_PIT_I,0.1
ATC_RAT_PIT_D,0.00625

To be clear here there are 2 issues being addressed. Your initial question about oscillation on the ground after arming and general in flight tuning. The former has very little to do with the later. Change mot_spin_arm until the oscillation is lowest or improve the ridgidity of your landing gear and then follow @xfacta advice for general tuning.

@xfacta The MOT_SPIN_ARM values are already the lowest, I didn’t make any additional increments, note that when the drone is armed the motor speed is very low, there is almost no noise.

Reducing the values of ATC_RAT_YAW_P and ATC_RAT_YAW_I the vibrations started in flight, I noticed by the landing gear that it is long and transmits very well. The oscillations on the ground gradually increased, you can see this in the video, I raise the throttle to 50% and initially I have no oscillations, but then it appears and increases, before it was instant.

I will do further tests by further reducing ATC_RAT_YAW and setting the INS values.

About pitch and roll I already have values that are doing a great job in flight, do you think I should adjust? Already had done Autotune before.