Motor order issue

I’m having issues getting the correct motors to spin. I’ve been following advice from @CBwintertime and @dkemxr at, but so far no luck. I was able to get to the point where only Motor A and Motor D are correct. If I then swap B and C, the other settings change as well.

Motor A (top-rt) / Servo1 = 35
Motor B (btm-rt) / Servo2 = 33
Motor C (btm-lt) / Servo3 = 34
Motor D (top-lt) / Servo4 = 36

I reference motor labeling as per Quad-X at

I’ve installed a MATEK F405-STD/Racestar 4in1 in an X-quad using betaflight frame type 12, also corrected for the board oriented 90 degrees right. I re-calibrated the AHRS and the HUD shows correct orientation. Messages confirm betaflight frame type is installed (‘Frame: Quad/BF_X’).

Appreciate any suggestions. Just two motors to go : (

Looks like that Racerstar doesn’t have a typical Betaflight X order like most 4in1’s do. I have some like that. Just re-arrange them until they are right.

I struggled with this a bit as well. A, B, C, and D are not 1, 2, 3, and 4.

It might help to take notes as you go, referencing the doc diagrams along the way.

You’ll get it right!

1 Like

It’s Racerstar’s fault for having a bastard layout!

Through trial and error I was able to determine the proper servo sequence. But now I need to reverse the spin on two motors.

I was unable to get BLHeli Suite to work with my fc. Is there a setting to do this in MP?
If not, I guess I would have to re-solder some motor wires.

I think you should troubleshoot this and not settle for it not working. It’s a BLHeli_32 ESC right? Post your parameter file if you want to work at it. Or get out the soldering iron.

I hear you Dave. Racestar specifies ‘BLHELI_S J_H_xx firmware’. What is a parameter file and how to retrieve it? I tried two different cables and two different PCs.


The process also impacted the fc. When I went back on MP it showed a position in the US Midwest (I am in AZ) and the AHRS off-kilter.

You need to use a different tool for BLHeli_S

Do you have SERVO_BLH_AUTO=1 set?

Post your parameter file.

Thank you @andyp1per and @dkemxr. I hadn’t set SERVO_BLH_AUTO=1. MOT_PWM_TYPE is set for DShot600. I also tried another BLHeli tool. I am uncertain how to post the parameter file, but perhaps this provides that information?


I find the sliders do not actuate the motors. How to correct that?

It does not. But at least you have passthrough working and you can reverese the motors as required.

Connect to Mission Planner and from the Full Parameter list Save To File button.

Don’t worry about that. Use Mission Planners Motor Test for this.

We were talking about BLHeli Suite so I thought the parameter file was from that.
MP041522.param (18.0 KB)

I tried to reverse two motors while connected with passthrough, then went back to MP, switched passthrough to off, then tested the motors. They did not show a reversal, so I again switched passthrough to on, returned to BLHS, but this time encountered the connection error. I thought I was making progress, perhaps I am not following a proper workflow.


Not sure what you mean by this (off/on). In BLHelisuite, reverse the motors that require it and write the setup. Confirm in Overview that it’s done. Then disconnect and power cycle the craft. ESC’s require a restart with any change. Then connect to Mission Planner and us Motor Test. You can only connect to one application at a time and there is nothing to turn on or off.

All sorted out now. Thanks again for hanging in with me.

I had thought SERVO_BLH_AUTO=1 had to be enabled/disenable (‘on/off’) each time I switched to BLHeliSuite.

Still don’t understand why the BLHeiliSuite motor sliders would not work…

Going to look for a different 4in1 next time I experiment with these small builds.

Great you got it sorted. Yes, you want BLHeli_32 ESC’s.