Servers by jDrones

Motor only works with either transmitter OR autopilot, but not both

(stevenette) #1

Hello,

I finally got my transmitter working, but now I am having issues with the motor.

I have a pixhawk connected to 1 servo in channel 1 and motor connected to channel 3. The ESC is programmable, but I took the brake off etc. My transmitter is a taranis x9D plus and receiver is X8R.

Problem: I have programmed a switch to have either manual, hold, or auto mode. This works fine. When in manual mode, the steering and throttle work just fine using SERVO3_Function = 53 (RCIN3). When I switch to hold or auto mode, however, the steering doesn’t work (Duh), but when I move the throttle up or down, the motor zooms up and down as well. To change this I switched SERVO3_FUNCTION = 70. But when I do that I can’t get the transmitter to work at all with the motor, and the motor sometimes goes out of control. (I burned one motor up this way I think!?)

How can I adjust any parameters to allow for transmitter control in Manual mode, and only manual mode, and everything else work like it should?

I will try to upload my parameter list if I can figure out how. Is there anything else I need to describe/upload?

Thank you!

(stevenette) #2

My parameters
parameters_5Aug19_1.param (13.3 KB)

parameters that make my boat freak out in sooooo many ways. Sorry Randy @Rmackay9…
mapping-boat.param (12.3 KB)

(David Boulanger) #3

Is this a skid steer type boat? In one parameter list it is set up as such although most people use 73 and 74 not 74 and 73. That really doesn’t matter because it all depend where the wires go. In the other parameter list SERVO1_FUNCTION is 26. So is this an Ackerman steering or differential steering boat.

Also, anytime you change a SERVOx_FUNCTION you need to reboot the Pixhawk.

(stevenette) #4

Hi David,

It is just a normal boat with a propeller and a rudder. The rudder servo is on channel 1, and the propeller is on channel 3. So servo1 = 26. I tried 21 but couldn’t find any difference. Servo3 = 53 if I want to use the transmitter, or 70 if I want autopilot to work.

I think the pixhawk resets automatically, but I will try to reset it afterwards now. I didn’t know that.

(David Boulanger) #5

No… Leave the throttle at 70. If in manual mode it is nothing more than a pass through to both the servo and esc. When in auto the Pixhawk knows what to do. Forget about the 53! And when you change the functions reboot. Based on your parameter list this has not been tuned so I would not expect an Auto mission to be pretty.

(David Boulanger) #6

When I say reboot it is simply unplugging it and then plugging it back in. No reset button.

(stevenette) #7

David,

What do you mean by tuned? Are you talking about PID? I was hoping to get the manual mode and everything working first, then I was going to adjust the PID loops.

Or are there other parameters to consider that are substantially important?

Thanks!

(David Boulanger) #8

Manual first with the Pixhawk set at 26 for steering and 70 for throttle. Pixhawk in manual mode.

(David Boulanger) #9

And make sure you have calibrated the Tx, Compass, IMU, etc. Follow the Wiki

(stevenette) #10

David,

I have servo1 set at 26 and servo 3 at 70. But the motor is still erratic, beeping, or doing nothing. When I change servo 3 back to 53, I can fully control the motor fine, but back at 70, I have no control. It just beeps (Some programming stuff from the ESC causing it to beep).

Are there any other parameters I am missing? Below are some modified parameters from Rmackay9.

mapping-boat_5Aug19.param (13.4 KB)

I just want my boat to go from manual to auto mode and float around a lake a little bit. I am starting to lose hair.

Thanks

(David Boulanger) #11

Sounds like the ESC is not happy. Does this boat have reverse? a .bin log may be helpful . Type of ESC also. RC_MAP seems to indicate you are using both the left stick and the right.

(David Boulanger) #12

If this ESC does not have reverse you will probably need to adjust SERVO3_TRIM. I think

(stevenette) #13

Hello,

I have 4 different types of ESC’s, all of which do kind of the same thing. They kind of work, but very erratically in auto mode, and then just beep like they are waiting for a radio connection. When I change servo3 to 53, I can control them all fine through my taranis. The main esc I am using is below

I have changed the trim from 1500 up and down a little, but haven’t really noticed any changes.

(David Boulanger) #14

I don’t think this ESC supports reverse. Try setting SERVO3_TRIM to the same value as your RC3_MIN. Also change SERVO3_MIN to RC3_MIN. People have had problem before with ESC that are not idle at 1500PWM. I think this is how to fix it somewhat. Basically the Rover code is designed for ESC’s that are meant to reverse I think. Reboot after the changes and give it a try. Can you post a .bin log. I think it would be useful.

1 Like
(stevenette) #15

Holy shit! You are amazing, thank you so much!

1 Like