Motor Interlock Enabled

Hello guys.

I am new to RC autopilot. I just finished building my GAUI X5 Helicopter and I am trying to integrated it with Pixhawk Autopilot. As I finished with all the calibration process, I found out that my Pixhawk is unable to arm for first flight test.

As soon as I powered on my Pixhawk and connect it with Mission Planner (as I am using Mission Planner as GCS), I try to arm the motor by holding the throttle down and rudder to the right, then my HUD window display this word, “Arm: Motor Interlock Enabled”. My LED light display flashing green, in which according to the manual, it means that the Pixhawk is disarmed. I search what does mean by this Motor Interlock Enabled word, by I end up knowing nothing. I really don’t know what that means.

I am using Stabilize flight mode when trying to arm the Pixhawk.

I am using:

  • GAUI X5 Formula Helicopter
  • Futaba T14SG Transmitter
  • Futaba R7008SB Receiver
  • 6S 5000mAh LiPo Battery
  • Hobbywing Brushless ESC Platinum-100A-V3
  • GUEC GM-601 Brushless Motor (1820W-910KV)

I really hope you guys can enlighten me with this problem. Appreciate your help.


Press the safety switch, throttle control channel, when the disarmament, to the lowest position in the PWM value of the channel!

Hi zhangsir,

I am sorry I didn’t understand what do you mean by “throttle control channel, when then disarmament, to the lowest position in the PWM value of the channel”. Could you please explain me further?

By the way, either I press the safety switch or not, I am still unable to arm the Pixhawk using my transmitter. Even after I press the safety switch, my Pixhawk didn’t arm and still saying that Motor Interlock Enabled and my motor is not spinning. My throtttle channel is connected to the channel 8 of the Pixhawk ‘Main Out’. When I tried to run the motor without Pixhawk, means that connect it directly to the receiver, the motor spins really well. I am really helpless with this Motor Interlock Enabled. Could anyone please help me out?


p/s: I attach the picture of my HUD window when I try to arm the Pixhawk using my transmitter.

Assalam o alaikum Usamah !!
I was facing the same problem. I was trying to Arm my helicopter but the same issue was there.
Later i came to know that this issue happens when u try to arm the autopilot when your throttle/pitch is at its max position. Obviously it looks odd that we arm by keeping the throttle stick on minnimum and tilting it right. Just go to your Futaba transmitter and Reverse the throttle/pitch servo In sha Allah your problem will be solved.
Update if done or not done ok !

1 Like

Hi Maaz,

I already overcome this problem couple of weeks back. I recalibrate back all the parameters and setting in the Mission Planner, and the next thing I found out that the motor is able to arm. Alhamdulillah.

However, I faced another unsolved problem during take-off. My helicopter tend to yaw when trying to take off. The helicopter is also very unstable and may crash is I continue the take off. It seems that the autopilot did nothing to stabilize the vehicle even I already set the flight mode to Stabilize mode. I suspected that this problem may related with PID tuning, but I have followed all the tuning parameters in the Ardupilot blog, but the same thing happens. I couldn’t solve this problem as I only have a little knowledge in PID settings.

I really appreciate if you could point out something so that I will be able to fly my machine.


Regarding to the “Pre Arm: Motor Interlock Enabled” msg, if i only do the radio calibration to identify the endpoints of each channel, the msg will continue, but if I manually adjust the travel of CH8 on the RC Controller to go a bit further, lets say a 5%, it will solve the Motor Interlock issue.

i.e. when I did the radio calibration, Ch8 pwm will be from 1100 to 1900, but if I manually adjust the RC Controller to go from 1050 to 1950 (do not do another radio calibration), it will solve the Motor Interlock issue.

I have set 1015 to 1917 but the interlock error remain.
my radio is Futaba T7C and not have more than 7 channel

Please post a param file.

Did you set motor interlock for an RC channel that your transmitter supports? Channel 6 or 7 would be fine. Just associate a switch on your transmitter to that channel to control it.

Do you have the ESC connected to the correct output on your flight controller? The default is the servo 8 output. You can change that as well, if you wish.

Yes i have output on Channel 8 and the function is 32 motor interlock. I i chenge to simple not work.
maybe need another channel to set same motor interlock?

If you only have a 7 channel radio then motor interlock has to be on a channel 1-7. So you have to set the motor interlock option on a parameter RC7_OPTION and remove it from RC8_OPTION. Then set a switch on your transmitter for channel 7. When you power up the flight controller then you want to have the switch for the motor interlock low (pwm <1200). That will prevent you from getting the prearm warning for motor interlock and allow you to arm the controller.