Motor/ESC keeps beeping

I have not done this, because I was running a stable version and so I can’t see this screen.

I will do this today itself.

Thank you.


Sorry for the delay. I was stuck with some other issues on the craft and was busy with some other work.

I did try flying again, today. After making the suggested changes. However, the problem remained as it is.
Problems -

  1. The aircraft does not remain in one place.
  2. There is still some lag. While flying, if I want to go left, or right or get it down, it lags after giving the desired signals.

Due to the lagging issue, I crashed it one time. Luckily, there was no damage. And then after a few crosschecks, I flew it again. This time, I was taking time to apply notches and was going slowly. The craft was stable this time. But the lag issue is definitely there.

I am attaching logs, in case it is required. - Feb 2022 - Google Drive

Thank you for your help.

There isn’t much to see in those logs, the flights are too short. I do see that you did set the Initial Tuning Parameters. I don’t see anything in the log or parameters to suggest a delay but you may want to choose a different channel for Flight mode. Channel 6 has some special functions for in-flight tuning that only can be set on that channel. In the future you may want to use them.

I have a FRSKY QX7
Channel 6 is a 3-way toggle switch.
In future, I may need only one switch in order to trigger a camera.
Currently, I am using 1 knob for Return to Home and 1 two way toggle switch for Arming the drone. As you know, there is one that goes to Flight Mode. I wanted to set 3 different modes as options for flight modes. So…using a 3-way toggle.

What do you suggest for these things now? Should I change the switch? If yes, which switch do you recommend me to use for Flight Modes? Something needs to be done because with lags, it becomes an uncontrollable flight. During landing, it becomes difficult to get precise judgements.

Thank You

All I’m suggesting is you assign Flight Mode to another chan. 5 is default. Use any except 6. This is just mixing in the radio to assign the switches to a channel.

I again went for flying, however without making any Flight controller switch changes due to lack of time.
The lag is there. but apart from that, what I noticed is,
The craft is balanced but it automatically travels towards the forward and left direction. It goes up as well as down. If it comes too close to land, I have to increase the throttle to save it from landing or harsh landing. But then it takes much altitude.

I also tried Alt hold mode to check this Altitude increase decrease issue. In Alt mode, the variation in altitude decreased by 90%, however, it was still there. In alt hold mode, the position was still varying. Do check the logs for clarity.


You were flying in Stabilize and AltHold. Neither of these modes will hold position.

Read the description of the Flight modes:
Flight Modes

Yeah, I know.
Stabilize and alt hold will not hold the position. Position hold will do that.
I just wanted to convey that in my previous drone, it used to remain stable, not going up or down or moving sideways when I leave the sticks. But it is not happening with this one.

I did alt hold to check if that way it stops going up and down.

Today I am planning to change the Flight mode channel and try with loitering and position hold mode. That will give clear idea on how much Altitude variation is there.

I flew in Position Hold as well as loiter mode and the craft remains stable. I think, in auto mission too, it will fly stable.
Thanks for your help throughout.