Motor doesn't go past 20% of power and starts fluctuating around that value

I’m building a fixed-wing plane and I have trouble finishing the build because of throttle issues. The motor I’m using is EMAX GT2826/06, TBS Crossfire Nano RX for radio, ESC is REDBRICK 100A with BEC and the FC is Matek H743 v3.

I’m on 4.3.1 arduplane firmware and when I force arm the model and slowly try to move throttle up it starts acting weird. The motor can’t reach maximum thrust, even though I move the throttle all the way up. After moving past what feels like 20% of the throttle, the motor gets somewhat shaky and starts fluctuating around 20% of power. Before reaching around 20% with throttle stick, the behavior of the motor seems rather normal (linear with throttle stick) as expected. I’ve already recalibrated radio multiple times. I have also tried programming ESC with different settings without luck (refering to http://atorie-m-m.main.jp/redbrick50~200A%20manual.pdf). I can’t seem to find the culprit of this problem.

I have also tried plugging ESC with motor directly to the battery and using servo tester to reach maximum throttle and in this case, everything works perfectly.

I’m attaching the log file of recent try: https://drive.google.com/file/d/1EySStk8ldp0vw5Fi2hwVzDL-69nXzLZk/view?usp=sharing

Is this on the bench without prop?
Are you testing a closed control loop in an open-loop manner, and wondering why the results are strange?

Yes I have tested this on the bench so to speak, with and without prop. Of course the motor is fixed on the airplane while testing for safety reasons.

The airspeed sensor is telling the firmware that the plane is not moving so the firmware limits the throttle because it knows there is something wrong. The test you are doing is invalid, and the results are also invalid

Okay, what would be the best way to approach this issue? Should I just finish the build ignoring this and test it in the fields?

Use mission planner motor test feature instead of the remote control. That one uses an open loop.

The motor test feature is all grayed out.

Video of the fluctuating behavior.
https://drive.google.com/file/d/1Hd_g9XGm7MtDEwYIxj_GL1RDFKIoNvrH/view?usp=sharing

Are you sure you have properly connected your vehicle via MAVLink?

Yes, I have tried multiple times, I connected it with a cable with no luck, then with wireless connection through TCP, still grayed out.

Then MissionPlanner probably thinks you dont have any motors configured to test.
Make sure that the motor servo output is not set to RC Passthrough or something like that.

2 Likes

Not sure what type of Plane you have but got something like this?

Nope. Flying in stabilized mode has nothing to do with airspeed.

Recheck your stick calibration.

Yes, of course. That fixed wing in the video is custom built.

I have recalibrated my sticks multiple times. The servos work perfectly with no issues.

Motor servo output is set at 70: Throttle.