Motor Balance Warning

since some weeks I get a very strange warning during Auto Analysis of my dataflash logs. It says:

Test: Motor Balance = WARN - Motor channel averages = [1586, 1556, 1510, 1462, 1503, 1504]
Average motor output = 1520
Difference between min and max motor averages = 124

Strange thing is: I never had any issue with balancing. My copter ist hovering perfectly.

Even stranger: It’s a quadcopter but the warning seems to talk about a hexa. (Six values are mentioned)

Therefore I think it’s a MP problem, not an arducopter problem. (It’s an APM 2.5 with V3.2.1; MP is 1.3.41 and

Somebody knows something?

All the best, Markus

1 Like

what the message is saying is you need to do an esc calibration, or one of your motors/esc is slowly failing.

in a hover the pwm out to the motors is those values listed. in an ideal world they would all be 100% exact while in a hover. as it shows that every motor is doing the same amount of work.

I would ignore this error for the moment, but watch to see if the difference changes over time

Hi Michael, thanks for your answer. I did an esc calibration - no difference. Perhaps your are right and one esc is beginning to fail.

One thing I still don’t understand: Why are there six pwm values listed in that warning message? It’s only a quad…

@Michael_Oborne ,
I know brand new components can be faulty.
But in my case, I have two adjoining motors (6 & 4) running slower than the rest on a HEX config.
Upon reloading 3.3.3 from testing 3.4.x, two different motors (5 & 1) were affected.
Reloaded once more and back to 6 & 4 running slowly.
This is after several ESC calibrations after each switch.

I noticed the same thing on my djis100+ frame with pixhawk. No escape calibration is needed and just thought it was a bug. My center of gravity is very close to center so I should not be seeing anything odd. My min/max difference was 100pwm. Any further ideas @Michael_Oborne

3.4.3 fixed the odd motor out issue I posted.
@nikker , I noticed the warning is only triggered if you have motor logging enabled (default logging of PixHawk is 176126 - almost everything)
Reduce logging to 958 ( Default+IMU ) gives you the basics and releases some processing power of the PixHawk.
I wouldn’t worry too much about motor balance