MOT_SPIN_ARMED not spinning

Hi - just upgraded to 3.1. MOT_SPIN_ARMED is set to 70 but no spin when armed. Any idea why?


You probably forgot the burning chamber preheater sequence…
What, your copter does not have a nuclear drive?
Well, maybe if you would have given more information about your setup as advised in the read me first post, we could have helped you :wink:.

I stand suitably chastised - humble apologies etc.

I have stock 3DR quad with APM 2.6 and the 880KV motors. Acquired new as RTF. I was running 3.01 and upgraded today to 3.1. This was after replacing arm/motor from crash caused by prop breaking early in last flight. Currently using Spektrum DX7 with AR7000. I had a few connectivity issues during firmware upgrade and had to start it 3 times. It also took me back through initial setup which I wasn’t aware it would do but that went fine.

My first thought when the motors did not spin when armed was that the firmware upgrade failed but when connecting to Terminal in Mission Planner it reports version 3.1. Arming is successful and test flight was as expected. I made a few other innocuous changes in parameters just to make sure they were taking properly. Not sure why the MOT_SPIN_ARMED isn’t working as expected.

I suspect the flux capacitor.


1 Like

It’s more likely that it’s the ESCs deadzone at the bottom of their range or that the ESCs haven’t been calibrated so the bottom of the range doesn’t line up with the lowest value being output by the AC firmware.

So a few solutions:

  1. try recalibrating the ESCs. … esc-motor/
  2. try increasing the MOT_SPIN_ARMED to something higher like 100. It needs to be lower than the THR_MIN parameter which defaults to 130 so if it’s still not spinning when you set MOT_SPIN_ARMED to 130 then you may need to increase the THR_MIN as well…this is pretty unlikely to be necessary though.

Thanks I’ll give that a go.


I had quite the smae problem using a Spektrum DX8 / AR8000.
Since re-doing Radio Calibration didn’t help, I checked my RC Calibration Values (RC1_Min … RC8_Min, RC1_Max … RC8_Max etc.) and found that some values were quite strange :
Throttle Min was around 1116/1117, while usually not going lower than around 1126.
Pitch Min was 1112, while usually being around at least 1120.
Since I’ve corrected these parameters manually, MOT_SPIN_ARMED now works again!
These low values appear - reproducibly with my RC - to be some glitches that are recorded for a very short period when moving these controls.
Maybe we need some kind of “glitch detection” or sanity check for the Radio Calibration in Mission Planner?!

Ok pfigger - good info - I’ll take a look at that too.


…but if you are seeing glitches on thge radio input that could be quite dangerous. that could lead to twitches in flight or false-positive radio failsafes.
I don’t think we’ve changed anything related in decoding the radio input in AC 3.1 vs AC 3.0.1. better to check if some fpv equipment is interfering with the receiver.

Well as it turns out it wasn’t the Flux Capacitor after all. Calibrating the ESC’s’ did the trick.


1 Like

Hmm, I’ve also a small problem with this feature. I’ve just updated my AIOP v1 today to 3.1 and later read about this feature to think “huh? didn’t notice yet”.

So I’ve connected the MP now to check the value. It’s was at default 70 and the motors didn’t spin on ARM. So I re-calibrated the ESCs to be sure. Still noting.
Then I started to raise the MOT_SPIN_ARMED value to 80…90…100. Still nothing.
Starting at 101 the motors finally started to spin on ARM. So I lowered it to double check -> 100…90…80… huh? Still working and with every step it was a bit slower. And yes, I DID write the values before arming again :wink: (this is why it got slower every time).

Finally at 70 it again did stop to work. Motors stayed still. So I went to 80 again… Still nothing… And so on!

Is this some bug or is there any explanation? I need to write 101 and then back to 80 to get them working?!

I have the same issue as DerFlash on this topic except I had to raise MOT_SPIN_ARMED to 110 before they started spinning on ARM. They started up quite violently, which freaked me out, but then fall really quickly.

As I lower MOT_SPIN_ARMED just like DerFlash they still worked, mine stop with MOT_SPIN_ARMED < 85, then I had to go back to 110 to start them again.

MIN_THR set to 130

I don’t like this feature (at least with my combination), the start up seems very violent for me, it would hurt LOL.

4x Turnigy Multistar 30 Amp Multi-rotor Brushless ESC 2-4S (1 Spare)
Reprogrammed from Defaults for Brake = Med (need to switch fully off), NiCd Battery, other setting are still default, i.e. Start = Med.

4x D2830-11 1000kv Brushless Motor (1 Spare)

All running on 3S LiPo