Module "QtQuick" is not installed - Kubuntu 14.04

I’ve installed APM Planner 2.0.15 on Kubuntu 14.04 (Trusty) using the .deb from When I try to run apmplanner2, I get the ‘module “QtQuick” is not installed’ error, just as described in Github issue 532. However, after installing the qtdeclarative5-qtquick2-plugin package as suggested there, I still get the same error message when I run apmplanner2.

Any ideas how I can get APM Planner running?

Full terminal output is attached: [attachment=0]qtquick-error.log[/attachment].

Maybe try (kind of a big hammer approach):
sudo apt-get install ubuntu-sdk
and see if that solves your problem.


[quote=“carpy”]Maybe try (kind of a big hammer approach):
sudo apt-get install ubuntu-sdk[/quote]
Done and rebooted - still getting the same error.

did you read /follow … / ?

Totally new here and to all this, not to Linux though.

I had the same problem, resolved it with

Which in terms installs a few more things (not entirely sure which is needed, but this will fix it). Seems like the .deb dependency list could use some fixing so it would install it automatically :slight_smile:

This is odd: I just installed Kubuntu 14.04, 32bit, installed APMPlanner 2.0.15, got the same error. Installed qtdeclarative5-qtquick2-plugin and it ran fine without the error. Is this a fresh install of Kubuntu, do you have any Qt development libraries, or other Qt stuff installed?