Mode not indicated?

The mode on the top right always says stabilize. When I flip the TX switch it doesn’t say anything [ yes TX is on :wink: ] or show a changed mode in the HUD. If I try and use the pop down list in hud and select another mode besides stabilize it will not change it in the HUD. I had this happen after installing 2.0.0. I went back to the older version but the new problem stuck with me. :astonished: Very frustrating… and not useable really. Obviusoly it’s very important to know what mode it’s in. Also I posted another thread it also never shows me if it’s armed or not. Verbally it does once but not in HUD. I tried to search this forum but I either really stink at it or … well… it’s probably me. But I’m sure Arthur and others are busy enough without answering the same questions over and over so if it’s already been discussed my apologies.

Other than that it’s a very nice looking layout!!!

ps using a
9.7" Cube U9GT5 droid 4.2… I think.


Would a tlog help? I have not tried to find and send one before hopefully there is some useful imfo. I would sure like to know why I cannot see what mode apm is in or if it’s armed.

That`s a very odd behavior. Is it working correctly with MissionPlanner?

Yes it works okay in MP.

I have a similar issue on my apm 2.0

If I use my newer 2.5 apm, it all works.

This issue is fixed for me. I think it was a tablet issue not DP but whatever it was it gone. It shows and verbalizes any change in modes. v2.2.1