Mode change to Auto only on Disarmed

Hello Everyone,
I have built a 2 engines boat, it has Drotek Pixhawk Pro autopilot installed. I was able to change modes with no problem and it followed the route in Auto mode, also with no problem. During the last trials, each time I tried to change from Manual mode to Auto, it failed, with no other problems reported (DPS and compass were constantly working fine, no telemetry problems). Although, it allowed changing the modes when the vessel was Disarmed. So to get the vessel following the route, I needed to 1. Disarm, 2. Switch to Auto, 3. Arm - it followed the route with no problem.
I do not think this is a proper behavior. We take the vessel out of pier manually and then start the route following. We do not want to disarm it on the water.
Can you please suggest me what may be the issue?

Hi @Cytryna,

Rover relaxes the checks when the vehicle is disarmed which probably explains why you’re able to switch into Auto mode while the vehicle is disarmed. When it comes time to arm though it should run those same checks though and stop the vehicle from arming unless you’re “forcing” the arm in which case it will arm but will then immediately switch the vehicle to Hold mode (unless you’ve also disabled the EKF check).

Maybe provide a log?

The issue though is probably that the EKF cannot calculate a good position estimate for some reason. This is normally because of one of these reasons:

  1. GPS lock isn’t of good enough quality (e.g. indoors)
  2. accelerometers haven’t been calibrated
  3. gyroscopes weren’t calibrated properly (perhaps the vehicle was moving when the autopilot was turned on?)
  4. compass is getting a lot of inteference from the frame or power wires (maybe there’s no external compass on this vehicle?)

It would also be good to confirm that you’re running Rover-4.2.3 on a modern autopilot and that the arming checks are enabled (e.g. ARMING_CHECK = 1)

Dear @rmackay9 ,
many thanks for your help.
I am sure GPS lock was fine and I am using the autopilot from the list - thanks for providing it.
This is true, there was no external compass and this may be a compass issue. I am now adding the external one and will try to configure it in the Mission Planner. We will see if this will help.
All the best to you!

1 Like