Mixed Inputs with Roll/Throttle on steering

Hello, this would be my first time posting something, I’ll try to give as much detail as possible! Not much different from lots of projects I modified a DANCHEE 4WD RC Car. It has front and rear steering everything worked well when defined everything as RCIN 1,2,3 and 4.
-Taranis X9D transmitter
-FrSky X8R receiver
-HobbyWing QuicRun 880 brushed ESC
-M8N Ublox GPS

My build is set as
Servo1 = Groundsteering
Servo 3 = Throttle
Servo 4 = Ground Steering (reversed)
(When front steering goes left, rear Steering goes right for sharp turning)

When I manually drive it, it is mixing the steering and throttle inputs when i try to only steer it takes it as if it was controlling throttle? Im not sure if it makes sense. While doing the motor Tests they all function individually motor A controlls the motors and Motor B controls the steering i tried reading the logs but didnt understand them ive been working with this project since february and its been a uphill battle trying to understand ardupilot. ill leave some of the logs

2023-03-19 17-58-40.bin (716.4 KB)

this is just one of the many issues im having :frowning:
long story short i cant make AutoMode Work nor manual driving work correctly.

Motor b controls the streering? Shouldn’t that be a servo?
It sounds like you need to straighten out the channel assignments beginning at the transmitter then at the rc inputs of the fc then at the servo outputs.

Yes, Its a servo, the car has 2 servos front steering and rear steering, i meant motor B as in the button that appers on mission planner, letting myself be guided by motor and servo configuration page.
Motor and Servo Configuration — Rover documentation (ardupilot.org)

I verified my Input and Outputs on my TaranisX9D
I had a few mix-ups your right, changed all the inputs and outputs to the AETR configuration and mission planner reads my channel 1 and 2 correctly at the radio calibration he reads them separately as if non interferes with the other channel.

I have fixed and checked all other small details and the problem only occurs when i try to establish the ground steering and the throttle inputs. as if both of them get mixed up, ill check each parameter to double check but Acro mode at least tries to work, it starts steering and accelerating haven’t tested it on the field so not sure what it is trying to do

I’ve solved my issue it was the Pilot_steer_Type was on 1 not on 0

Nice, all these setup paramerters affect the mixing of channels etc and it it can be tricky to get to the beginning of having a working model to then start fine tuning.

1 Like