Servers by jDrones

Misson Planner OSX

@Michael_Oborne, after watching your presentation the other day I went and installed the OSX version of Mission Planner. (Great presentation by the way, I found it useful!)

When I try to run MP on my MacBook I get the following error:

And the screen looks like this:

I suspect the two are connected. Is there something I need to do on my end to fix this installation?

Also, I’ve willing to test this out for you. Where is the best place to post any comments about this version? I have no experience with Github other than downloading different firmwares, in fact I had to create an account just to download this program.

Thanks for all the hard work!

if you go full screen does the scale return to normal? also what is the native resolution of your screen?

Going to full screen doesn’t change it to normal, just spreads everything out more. I tried to cycle back and forth and it was constant.

The screen shot was from the built in screen on the laptop. 2880 x 1800 (15.4")

Here’s full screen:

I moved the window over to my second screen, 1920 x 1080 (31.5") and that just looked worse. About the same size as the built in screen but pixilated. (not useable)

ive push some changes that should make it a little better.

That looks much better! Thank you. Still a bit small, but that might be bordering on old-man eye issues and not a system problem. Also that error on start went away.

I opened up a log file and tried to use the Show Parameter function. I got the following errors:

When it did finally open the parameter screen all I got was this:

Also in the log files, none of the pre-set graphs (mavgraphs) were available. The menu was blank.

I’ll try to connect it to a drone today and I’ll let you know how it goes. Thanks!

Unable to connect to a drone. I tried direct USB and over SiK telemetry radios. The screen shot is from direct USB. Just to verify things I did dust off APM-Planner 2 and it was able to connect without issue.

yeah, full param tree will never work on non windows. i will option it out
full param list will work

im looking into this now, hopefully have something that works in a short while

2 Likes

ok new version again.

tested with a cubeorange on osx.
untested tcp/udp etc

also i would suggest going fullscreen, then it looks like its meant to.

1 Like

It does look better full screen.

Was able to connect over USB. Haven’t tried other methods yet.

This might be difficult to explain but here goes: Whenever I try to use a data entry field (Example: search function in a parameter list, or IP address for my ADSB server) the screen goes white. I can type in a value on that white screen but when I press enter nothing goes to the data field. So far any data entry field I’ve tried has done this to me.

@Michael_Oborne, I just tried build 131. I still can’t enter data into any field.

yeah, i had seen this. working on why its working on other platforms, but not osx

1 Like

Just tried 136. No change, still can’t enter data.

sorry about that, been busy on other projects. give me abit, and ill report back here

No worries. I just noticed you had some updated builds so I figured I’d try it out and let you know. Thanks for all the hard work on this!

Servers by jDrones