Misson Planner does not Dispaly Flight Modes or Parameters

I have a problem with MP 1.3.48 and firmware 3.4 in a Hexicopter. The Mission Planner does not display the parameter list on screen also no flight modes. have tested on two PC’s both Windows 10. APM 2.4 works fine on both any sugestions appreciated.

Sounds like a driver problem. If it can’t read the parameters it will not be able to read the flight modes.

How are you connected to the flight controller. USB or radio?


Thanks for getting back Mike. Yes I am communicating via Mav link Radio but just to fill you in a little I have also tried USB but not on both PC’s only on my Laptop, as I said both are Windows 10 and up to date via automatic upgrades. All other functions seem to be OK and the Quad is definatly comunicating with the PC, I have set up Radio, acceleration and compass with no problems

Not sure I follow the problems you at having , but have you tried:
In MP when unconnected to going to FC the “Configuration” tab and using the drop down box labeled " Layout", selected “Advanced”, which will show the advanced settings if that is what is missing.

In MP hit “Control F” to bring up a menu, then pressing the " Param gen" button, will get the flight modes to populate.

Hi Joe,
Thanks for the reply, however you are missing the point. Its not that I am unable to view Advanced Paramerters I am unable to view any parameters. I also can not view flight modes. As reported originaly I am able to view Parameters and Flight modes when using APM Planner on the same PC which seems to suggest I have got a setting wrong during or post installation. I have completly deleted and reinstalled MC twice all to no avail. The problem is not that deabilitating as I can us APM Planner which seems to me to be a more stable and better product. Thanks for all taking the time and effort to reply, if any one has the solution it would be interesting but if not No problem

So the issue is that Mission Planner loads but does not connect to the flight controller.

I have been using Mission Planner for years now and have also used QGround Control as well. Both work out of the box without any special setup. I have not used APM Planner though.

Perhaps if we new more about your hardware it may help with what maybe the issue.

I have used all versions of Windows with Mission Planer without issue.


Hi Mike,
Please read my posts. I have connected my hex to MP using both Radio and USB. Connection is not my problem!!! When I am connected MP does not display Parameters or Flight modes, all other displays aseem to be OK / good. I am sorry if you still dont understand but I am unable to to further simplyfy my request for advice.

Well, the first thing Mission Planner does when it connects is read the parameters from the flight controller. Once that fails it is not possible to display your flight modes since they are stored as parameters on the flight controller.

It would seem you must have a clone or something and perhaps you need to stay on APM planner as it seems to work for you.