Missions end with 'Loiter' rather than 'RTL'

I’m using MP ver 1.3.32 to set up surveys which is working great. I have noticed that my Missions are ending by switching to ‘Loiter’ mode at the last way point. I have the ‘use RTL’ tick box checked when planning the mission and I know in the past that worked fine but it doesn’t seem to be having any effect on the current missions. Unless I manually change to RTL the copter just Loiters at the last way point.

I compared my current missions with previous missions and I can see that the issue is simply that I haven’t ticked the option for creating a take off and landing way point. I used to do auto take offs but I prefer to take off manually just to make sure all is well before sending the copter off on it’s mission. So I’ll just add a manual RTL way point at the end of the missions now.