MissionPlanner update failed on beta update

MP is unable to update from BETA with the following


i would try again. most likely a server/internet issue

1 Like

regrettably, the behavior is constant in the past 2 days. Simply fails on every try. Definitely not a network issue! A server issue might be more likely.

Is there a link to download a nightly build of MP?


Well it worked yesterday and tested a couple minutes ago and still worked. So it must be a network/provider issue on your side.

Hi Andras @Eosbandi,
Actually, in stack trace there is no indication to Network/provider issue and since for you it is working and for me not, does not indicate that your claim is correct, it is only convenient.

However, reading entry from a zip file while it is being read from the DownloadStream has more potential to failure, some copying between streams is done and all that is done asynchronously @ Update.GetNewFileZip might have some unforeseen issues like the one that I am seeing in the last few days.

Hi buddy i get that issue if i don’t run Mission Planer as administrator when trying update

1 Like

Hi Colin @yak-54, you nailed it :raised_hands: :raised_hands: :raised_hands: .

Even though I do not understand why this should happen, no network / operator issues are involved in this, only permissions? @Michael_Oborne.

Thank you so much for your help on this.

Best Regards,