MissionPlanner.exe with Mono on Mac Big Sur fails with System.DllNotFoundException

Today I fired up the Mission Planner app and plugged in my new PixRacer. It recognized the device but wouldn’t flash a new firmware. There were no errors, it just didn’t don anything.

It also didn’t seem to have access to the GPS. I’m sure OSX isn’t letting it access the location. I have to give QGroundControl permission each time I start it, but I don’t know why I’m not prompted for Mission Planner which thinks I am in the Atlantic Ocean somewhere off the west coast of Africa.

So I have SITL running on Fedora on 192.168.1.92 (MP on Windows on another PC can connect to it and execute a mission). I try MP MacOS (same version as on previous posts and this happens:

Initiating TCP appears 127.0.0.1 and seems impossible to change.

BTW, the TCP connection on QGC:


It is a DO_SET_REVERSE test on a Balance Bot. The mission had been loaded on it from MP on the Windows machine mentioned above.

That looks like a problem I am seeing with MP on Mac. I can’t enter any values. I tried changing some parameters, every time I click on a field it pops up this full screen editing window, I type in the new value and presss enter - which takes me back to the original field with the old value still there as if I didn’t type anything.

ill check this out. thanks for the video

I’m seeing the same issue when I try MP on Mac.

1 Like

i just added a workaround for the no typing issue on the osx build.

still not 100% but you can now input text

2 Likes

Yes, much better. Video (TCP).

Some observations:

  • On a ultrawide monitor characters appear compressed, so window is stretched above to 1920x1080 for the capture. This is not remembered.
  • No speech. Should something be heard?
  • Being a balance bot, the tuning window shows the pitch. I can’t redimension that window.
  • No auto pan.

For UDP (same machine) the same as before: automatic connection, finishing in
image
forever.

Sorry for the dumb question Michael - but where do I find the new build? The link @james_pattison originally published still shows the old build (I think).

try here

1 Like

can you start the app via terminal? i would like to see the console output, as autopan should have been working

as for speech, that should have worked. so again something i will need to check

MP_MacOS_terminal_20210909a.txt (796.8 KB)
(Start and close: nothing done)

Let me say that first I put the UI in spanish and also the messages, so, if it should have worked, I will try again in different ways.

In the QGC video above I didn’t include sound in the capture, since QGC is poor at this. I didn’t do it also on this MP capture, but while the mission was running nothing was heard, and I checked that there was sound on the system.

So I tried on a Mac Mini M1, with defaults, expanding MP on a 5K monitor full screen, and capturing full screen.

The capture resulted 4096x2304 instead of 5120x2880. Apple seems to need decades to fully debug Big Sur on M1. Here it is.

More observations:

  • Certainly no sound, even explicitly enabling its MP options, as can be seen on the video. The microphone is heard.
  • The Auto Pan can be seen at the end of the video. It works a bit, but certainly not as in Windows.

After comparing Auto Pan on this mission with MP Windows, I found same behaviour. So I separated the two extreme mission waypoints, and really Auto Pan is clearly seen, so may be the waypoints were too near for Auto Pan to be triggered or whatever.

So the main points are:

  • No sound.
  • The Tuning window (with pitch on videos above) occupies half the height. I don’t see how to redimension it.

I agree with Webillo, The tiny windows and fonts are very hard to read. I’m using this on a 13" MacBook Air and I have to use a magnifier to read information in the postage stamp size instrumentation window in the top left hand corner. There doesn’t seem to be any way to resize it. I don’t think this is going to work out in the field.

I just loaded build 378 onto a 15" MacBook Pro. I was able to enter data. And the screen doesn’t look too bad on this one.

I haven’t tested sound yet, and I haven’t connected it anything yet. Honestly I’m happy I can finally enter data fields.

Edit: Just connected it to a quad. No issues there. Something happened in the planner screen that caused it to lock up so I had to re-boot MP. If I can re-create that I’ll post it. I also couldn’t get any sound working. I enabled the voice and tried things that should have given me some response, but there was nothing. Still pretty pleased with this.

1 Like

ideally logs from the mission planner directory would help for the hang’s the “missionplanner.log” files

Where and which?

From MP_MacOS_terminal_20210909a.txt above:
Data Dir /Users/xxxxxxx/Mission Planner/
Log Dir /Users/xxxxxxx/Mission Planner/logs
Running Dir /Volumes/PartApple/DescargasPA/osx/Mission Planner.app/Contents/MonoBundle/
User Data Dir /Users/xxxxxxx/Mission Planner/
log4net:ERROR Failed to find configuration section ‘log4net’ in the application’s .config file. Check your .config file for the and elements. The configuration section should look like: <section name=“log4net”

On /Users/xxxxxxx/Mission Planner/logs there are the usual .tlog, .rlog and .tlog.jpg files.

locate doesn’t find anything even after its update on both Intel and M1.

BTW1, analyzing logs on the M1:


For getting Alt I had to click I, one above.

BTW2, playing a .tlog on Intel:


Also, no sound.

1 Like

Hi @Michael_Oborne, I notice the latest build 402 is tagged as “beta”. Does this mean this is going to become a released product soon? That would be great news.

BTW - you only seem to have “iOS”, but as I understand it Apple now considers iPad OS to be a separate platform. https://developer.apple.com/ipados/ Will you be releasing for iPad too? It seem to me that Mission Planner will be almost unusable on a phone size screen, but might be usable on a tablet.

i have tested MP on a emulated 10" ipad yes, back at the start of the year. but i dont have a developer account, or a new enough “I” device to test it properly.

1 Like