Mission Planner won't launch "Fatal Program"

Hi there! This is strange b/c Mission Planner 1.3.49 was working fine on this device (Microsoft Surface 3), I connected to the Pixhawk 2.1 via USB, updated firmware, parameters, etc., then when I tried to connect via the HobbyBro Modem, it wouldn’t connect. I closed MP and when I tried to launch it again I received the following error:
FATAL Program: Fatal app exception
System.FormatException: Input string was not in a correct format

I’ve tried uninstalling the software 4 times, restarting device several times, deleting root folders (after uninstall) including “C:\ProgramData\MissionPlanner”. I also tried connecting to PH via USB again, uninstalling and reinstalling USB driver and still getting error.
I have another identical Surface, and MP runs perfectly on that device.

Any suggestions?
Thanks in advance!!!

please try deleting
"my document\mission planner\config.xml"

1 Like

Hi Michael, thanks so much! I ended up doing a factory reset on the device and that solved it… I like your method better :wink:
We are an industrial UAV provider so we’ll likely run into this again - if we do, we’ll be sure to try what you suggested.

Thanks so much!