Mission Planner with Copter 3.5.8 showing Bad Logging


After letting my quad stand on the shelf for some months after a crash I wanted to get flying again.
But after loading the latest FW and setting everything up I couldn’t arm it since it keeps getting errors of
"Bad Logging"

I tried to format the SD card that came with it but it didn’t work.
I also tried to switch to different cards like one SanDisk Ultra but it didn’t work either.

Seems like whatever I do it still gets me the errors.

Is it broken from the crash? Becase it didn’t give me errors like that after the crash, only now after it’s been on the shelf for 4 months

Thanks in advance

I had the same problem with Arduplane 3.8.
I solved it by formatting the 2GB SD card with FAT16. I also tried different cards, so I am not 100% sure it was formatted with FAT32 before, but now it works again.

1 Like

Two things

First things first, the current version of copter is 3.5.2. If you are running -RC8, you are on a very very old beta. Please update to the latest copter firmware and re-test before troubleshooting any further.

If it still doesn’t workL

  1. Check your LOG_BACKEND_TYPE parameter. If it is set to 2 or 3, and you don’t actually have a companion computer to do external logging, you will get this error. Set it to 1, which is normal logging just to the Pixhawk.

  2. Check your LOG_BITMASK parameter to make sure it isn’t set for something invalid,

Having the same issue after update not sure what happened. Changed Log_Bitmask numbers but nada did work before upgrade.


I ran the latest version of copter.

But I had backend set to 3, and that makes sense since I used to have a companion computer connected to it.

It’s working now! Thank you very much!

1 Like