Servers by jDrones

Mission Planner update crashed and now won't re-install


(mpjf01) #1

I was using Mission Planner earlier today as usual having said no to the prompt to update when it started up as I was in a rush. At the completion of my task I went to check for the update and told it to install. The installation terminated unusually with a 404 error. I tried to restart the program and received a different abnormal termination which I didn’t record but IIRC was the same as the one I received later - see following. I then uninstalled MP from the Windows control panel and went to the documentation and downloaded and reinstalled from scratch. The error messages are in the screen dump below. I think these were the same as I saw when the update failed and I tried to restart. I am using Windows 7 Ultimate 64 bit.

I would be grateful if somebody could give me some idea of what I need to do to get the program working again. Thanks,


(Michael Oborne) #2

you will need to reinstall from MSI, or extract the zip file into the directory and replace all files


(mpjf01) #3

As I wrote I installed from scratch as per the documentation in the wiki. The file I used was MissionPlanner-latest.msi as described here - http://ardupilot.org/planner/docs/mission-planner-installation.html after a complete uninstall of the version that was there before.

What other steps are required please? I’m not sure what the “zip file” you refer to is or what directory you mean.


(Michael Oborne) #4

if that didn’t work, try uninstall again, then delete the MP install directory. then reinstall


(mpjf01) #5

I deleted the whole directory and reinstalled and it is now working. Thanks. I’m not sure what was in the directory but it was many times larger than the .msi file that I downloaded for the reinstall.

The issue I have now is that MP locks up and I get a Windows message that the program has stopped responding when I attempt to load settings in SIK RADIO.