Mission Planner unable to connect

I’ve taken back my quad project after a while and surprise: mission planner cannot connect to FC neither directly via USB neither via telemetry module (but I connect throught Companion via TCP or UDP and can connect with “Tower” app on mobile via telemetry module).

I get this message… any idea?

thanks a lot,

according to error message comport is already opened by another application. Comport can be opened only once. So this error appeared.

Check if any other application with access to serial port is running. Try to use Mavproxy to connect to quad, so You exclude MP connection problem.


usign MAVProxy (running on Raspberry pi ver2 and/or ver3) I can connect.

Using MAVProxy with windows message is “could not open port ‘com15’: WindowsError(2, ‘The system cannot find the file specified.’)

I tried with different boards (VRBRain5.2, VR micro Brain and PIX4 clone) and different COM ports, but always the same error/problem.
I have windows 7 professional with service pack1.

Thanks for support

If your screen shot indicates the baud rate you are trying to connect at via USB it is wrong. The default USB connection baudrate for USB is 115K

I tried with 115200 also, but still same problem…


Antonio do you have a bluetooth device grabbingh com15? Are you sure com15 is the port the FC is connected to?

You installed all the USB drivers when you installed Mission Planner? I know the questions are rudimentary just trying to cover all the bases since you are stuck.

yes I did.
I’m going to de-install mission planner, any other GCS (e.g. MAVProxy, UGC) and drivers (and DFuse etc. installed with taranis) and re-install again, let’s see if windows stucked somewhere…

I solved deinstalling all drivers and all GCS SW and related user data. Re-installing from scratch solved the issue… so it was a microsoft windows driver problem.

PS: I’ve tested only with Windows10, I’ll test with windows7 Pro in the next days