Mission Planner Survey Grid Issue

I am trying to use regular Survey Grid and it is extremely slow. This pops up when I am trying to plan a mission. Screenshot attached. Mission planner 1.3.38.

Turn off the “footprint”. Should go away.

It locks up…I have no control. As in Mission Planner Doesn’t respond. I had to wait a while for this to even pop up. My computer is more than capable.

turn off footprints, and make sure your home alt in flight planner is set correctly.
your screenshots shows your home alt as 100, but yet the coverage areas is in the 220m range. ie fix your home alt.

I cannot turn off footprints because mission planner crashes when trying to get to this screen.

So now it loaded up and I was able to turn off footprints. But it sure was struggling there for a bit.

fix your home altitude.
right hand side, under write wps, currently set to 100.

set it to something like 250

That worked. Thanks Michael. Why did that work?

the footprints are calced based on your height above ground level, in your case you had an extra 150 m. and the footprints where showing that. because there was so much overlap between photos and the extra 150m was expanding the total photo area, the cpu usages grows, until it becomes unresponsive.

Alright. Thanks Michael.