Servers by jDrones

Mission Planner SITL Software error

Hey! I’m using Windows 10 Latest Edition. I just get the error “Failed to download the SITL image” and I dont know why. Also I get series of errors when I start the Mission Planner any advices?

Errors are:
System.UnauthorizedAccesException: Acces to the path denied.
at System.IO.__Error(int32 errorCode. String maybeFullPath)
at System.IO.FileStream.WriteCore(Byte[] buffer, int32 offset, int32 count)
at System.IO.FileStream.FlushWrite(Boolean, calledFromFinalizer)
at System.IO.FileStream.Dispose(Boolean disposing)
at System.IO.Stream.Close().
at System.IO.StreamWriter.Dispose(Boolean disposing)
at System.IO.StreamWriter.Close()
at System.Xml.XmlTextWriter.Close()
at MissionPlanner.Utilites.Settings.Save()
at MissionPlanner.MainV2.SaveConfig()

looks like a permissions problem. for some reason Mission Planner cant access you my documents folder

I even tried to run it as Admin but it did not work

@SouSageYa Sir Please uninstall and reinstall the mission planner.

I uninstalled and reinstalled it as you said but it did not work

@SouSageYa ok, Sir. i know that one only :grinning:

I Guess there is not a fix about this problem. “Failed to download SITL image”

Install on different location, NOT under C:\Program Files (x86)\Mission Planner
Try path like this: C:\Mission Planner

Didn’t work sorry… Any other advices

Are you Administrator on that Window 10 machine? Try login with Admin

1 Like

I tried this and It worked somehow. I’m currently in shock. Why my default user does not have the admin privileges. Appreciated.

This is driving me crazy for real. I’m Admin, I’m starting it as administrator. Uninstalled cleanly and installed it. But still it says it cant reach something in my PC. Whats wrong with it. I tried a different clean windows download and it says no “Config.xml” file IDK What to do rn. HELP ASAP!!

And it turns out that my Windows Antivirus blocks MissionPlanner somehow

Servers by jDrones