Servers by jDrones

Mission Planner SITL error

Anyone ever come across this error before?
My SITL started from mission planner was working perfectly then I changed the MAV_DATA_STREAM_EXTENDED_STATUS to 10Hz and it suddenly stopped working and started giving me this error.
I’ve tried uninstalling MP and deleting the MissionPlanner folder that’s created when MP is installed and then reinstalled it but I’m getting the same error.
Are the SITL params lurking in some folder I haven’t been able to find?
Any help would be much appreciated. This is driving me insane!

I have the same thing. Yesterday i had no problem but today i couldn’t start sitl. I tried 4 or 5 different computers, re-installing, cleaning Mission planner folder etc. After that I tried to copy an older Mission Planner folder that i saved before, and it worked. If you don’t have older files probably, you can download those sitl files from “firmware.ardupilot.org” and copying them to Mission Planner folder.

A recent change in ardupilot code broke SITL in mission planner (vehicle info is loaded from the ardupilot). I submitted a PR to fix it. Please stay tuned till it goes trough.

There is a new Beta which contains a fix. Please update.

Hi still getting the error here. Just started getting the error midday on Saturday - appeared out of nowhere. Assuming that the simulators were recompiled? Is there any method to fix this on my side?

I am getting this error as well Craig, Cant seem to find any solution for this… but then again I am very new with sitl

Hi all,

I’m facing the same problem. Re-installed last version of Mission Planner (not Beta) after it stopped to work last week.
Any advice ?
Thanks

Get the latest Beta. It works.
image

Thank you Eosbandi, now it works

yo botuve la ultima version beta y da otros errores y sigue sin funcionar, alguna sugerencia?

how can we get it?
I am still new to mission planner as well and it crashed

can you share the .exe file if you built it. @Eosbandi

Simply update to latest Beta version. From the Help screen the big green button on the bottom that says “Check For BETA Updates”. Press it…

Servers by jDrones