Mission Planner Simulator has stopped loading aircraft simulators

Today, out of the blue, my Mission Planner stopped allowing me to load a vehicle simulator from the simulation tab. It gives me a message as follows:

An error has occurred. Newtonsoft.JsonJson.JsonReaderException Unexpected character encountered while parsing value T. Path ‘ArduCoptere frames IrisRos external’ line 109 position 28…

I have tried everything including a fresh install of Windows 10 and a fresh install of Mission Planner but still the error comes up. I am assuming that it is something on ArduPilot’s side given that it is a JSON error and given that it happens when the simulators are being loaded after selecting the vehicle icon. Is anyone else having this problem with mission planner loaded on windows or is it unique to my machine. Any insight would be greatly appreciated!!!

This happened to me today as well. Updating to the most recent Mission Planner beta fixed the issue.

The same problem here… Even installing the new version i got the same error…

Well, sitl is broken again!


Latest beta works just fine here…

Most people use stable, I guess.

I wouldn’t say that. Mission Planner often lags feature development of Ardupilot. Many people update MP to latest beta everyday…

Well, we have a different experience then. I never seen anyone who uses beta. Even while I fly Ardupilot since it was born, I never used beta MP. I simply never seen any mention that there is a reason to use beta until today )
I’m sure that ordinary user will just download stable.

Well OK, whatever works for you but check out the MP Changelog relative to Ardupilot firmware releases. 15SEP20 for current Stable MP…

Perhaps “beta” isn’t an appropriate description for most new releases of MP.

And MP SITL loads the latest Dev version right? So…,