Mission Planner Simulation

Hi,
I am new to Mission Planner, and trying to get everything working. The documentation is comprehensive, and a lot to take in. So far my Mateksys F765-WSE talks to Mission Planner on my laptop via XBee modems; I get GPS fix and location on the map, also RC and stabilization works. I want to have everything working in a rig setup before installing it in my Skywalker fixedwing.

I have MP 1.3.76 running on a Windows 10 laptop. Today I tried Simulation and could not get it to work. Something is obviously missing since I get this message several times from ArduPlane.exe : “MKFIFO failed with No such file or directory”

It seems to me from the documentation, that additional requisites need to be installed. Do I need to install Linux under Windows 10? Or, since I have Ubuntu 20.04 alongside Windows on my hard drive, should I rather run Simulation there?

Please point me in the right direction,

Thanks, Helge.

What are the errors exactly?
Copy paste it.

Thanks for the reply. Here is how far I get:

Seems like the sitl is still running.
Can you try to connect to the vehicle with TCP at port 5760?

I did. Regretfully I got the same result.

Hi,

I got the simulation to work now. After a steep learning curve I could fly a mission with takeoff ,several waypoints, and landing.

Still I get the error messages shown in the screenshot in my post #2. Is there something I should configure to get a clean loading of the simulation, or should I just leave this and continue simulation?

Thanks, Helge.

Hi HWal , How to run simulation ?

Seems like you’re disarmed.
Arm first, change flight mode to auto and send mission start.
Does your flight plan include a takeoff mission item as the first item?

Mustafa Bey cevabınız için teşekkür ederim , yıllardır önce arm edip hemen ardından mission start komutu vererek uçuş yapıyorum ( 1.3.73 ile şu anda aktif olarak bu şekilde uçuşlarımı gerçekleştiriyorum ) , dediğiniz gibi uçuş modunu auto yapıp da denedim ama yine aynı hata mesajını aldım . MP 1.3.74 e kadar sorun yoktu ama 1.3.75 den sonraki versiyonlarda ne simulatorde nede arazide gerçek uçuşta otomatik uçuş yapamıyorum bu nedenle malesef eski versiyon kullanıyorum . Uçuş planında takeoff komutu var. Hem windows 10 hemde 11 de denedim sonuç yine aynı . Sizin simulator şu anda çalışıyormu ve MP sürümünüz nedir ?

I use MP 1.3.76. To get simulation running I did this:

SIMULATION → Plane icon → Latest (Dev)
Check green CONNECT icon on screen top right
PLAN → Load File → Choose a flight plan already made with TAKEOFF as first command
PLAN → Write
DATA → Actions → Mission_Start → Arm/ Disarm → Auto
In my case, the sim runs now with a “flying” plane, despite error messages during loading of the sim.

Helge.

Thank you , plane is run but copter doesnt run. Please try multicopter ?

I tried multicopter, and I am sorry I could not get it to fly.
After that I went back to a plane again, and it flies.

Helge.