Mission Planner simulated mission speed

Mission Planner simulator does not run over 1000cm/s.
Simulator needs to reflect all ranges of all parameters to give a good simulation.
For this case - I need 1500cm/s

I don’t understand your request. I need more info

My apologies,

In my example:
When connected to the simulator as multirotor quad, you can have WPNAV_SPEED set to 1500cm/s but the actual simulation will be ran at 1000cm/s - as if WPNAV_SPEED is set to 1000cm/s.
I have triple checked that the parameter has been saved and displays 1500cm/s.
That will give a bad simulation.

If you try to perform a MavLink command “change speed 1500”, when you click change speed, it will display 1000 max.

Requesting that simulator can be ran at the same speed as ArduCopter - allowing (2000cm/s).

Yes, most larger (450mm+) crafts become unstable at speeds of 1200cm/s but I do have a craft that is stable at 1350 and another is stable at 1500.
I had one that was stable at 2000cm/s:

try changing the max lean angle. my guess it is a setting that is not set high enough to go as fast as you want.

Max lean angle is set to the same as the craft…3500
As shown in the shared flight log, the craft was set to 3500 and reached 1960cm/s

the simulator uses the same code that is loaded on hardware. so it is either a setting, or a limit of the virtual quad defined in SITL.

I would think it is the latter - limit of virtual quad/ multirotor
Could that be increased to match expected performance?


You have been rude interrupting other discussions pointing people here and been offended when your post is flagged off topic. I offer to look at this for you and I find that not only is there not an issue but your questions have already been addressed by Michael Oborne.

So to summarise. The aircraft in the simulator flies at 15m/s at an angle of 45 degrees. 45 degrees is the maximum lean angle in the latest release that navigation can use. You have limited the maximum lean angle and slowed down the aircraft in the simulator to 10m/s. Michael pointed this out to you and you acknowledged this to be the cause of the speed limit.

Your problem is not that there is an issue with the simulator. Your issue is that the aircraft in the simulator does not match your personal aircraft.

Please do not waist developers time by misrepresenting feature requests as bugs or problems with the code.

1 Like