Mission Planner screen issue once armed (video included)

I am currently running the latest beta version of mission planner and there seems to be an issue once you arm the aircraft the screen gets resized and jumbles everything together. This only seems to be an issue on my surface pro 4 running windows 10, have not seen an issue on any other pc’s or laptops running windows 10 or 7, seems to very specific to the surface models as another friend has an older model surface and it also does the same thing to him, doesn’t matter if it is arduplane or arducopter both seem to resize the screen once you arm the uav. Here is a short clip showing the problem.https://photos.app.goo.gl/QNBfvVQsBMNMuTcj9

This is a known issue that you can solve by some Windows font auto-scaling magic, details of which I don’t precisely recall this morning, and have no time left to research. Search through MP Git issues or here on the support thread, and you should find a conversation between Oborne and me about this.


I have the same problem on one of my computers. I thought it was just me. Need to research .

I just scrolled through a few months of this support thread and didn’t see it. My old computer is good but my new laptop has the issue but only recently.

This only recently began appearing for me, probably about a month or so ago. Figured it might have something to do with touch screens but my General Dynamics GD8200 w/touch screen works perfectly no issues. I also looked through @wkf94025 posts to see if I could find the posts he was referencing but was unable to find them. Will keep digging!

I believe the bread crumbs are in the github issues for Mission planner, not here on the support form. Either that or on the gitter channel for Mission Planer.


Here is a short topic that might provide some fixes, have yet to try any of these yet.

please try the latest beta.

this is a windows issue with screen scaling. no idea why windows decides to change it after the app has already started.

1 Like


I downloaded the most current beta this morning 0745MST and still had the arm/disarm scaling issue. I tried arming from the action tab as well as the RC both made the screen change size and make the buttons unreadable.

I’m still trying to figure this out. I have an old computer with Windows 10 that works fine. My newer high powered Windows 10 computer that I use for video editing is giving me the problem. Going to try changing some screen scaling and see if I can get it to display properly.

This is discussed on github issues for MP here. Short summary is that you have to change the attributes of the MP exe on your machine to stop Windows from doing what it does.


What @wkf94025 posted earlier from the github chat solved my issues with MP rescaling.