MIssion Planner running in VMware Fusion on Mac -- no HUD?

I am used to running MP inside of VMware Fusion on my Mac and I used to see the HUD display in the Upper Left part of the MP main window.

It is not visible anymore – just a black area where it should be. I am using the latest MP and the latest Fusion on my Mac running OS X Mavericks. There are errors in the MP terminal about the HUD but the rest of the interface seems to work – tuning, configuration etc.

BUT… I was trying it again just now, and the HUD did appear after a delay. I was trying to capture the error messages from the terminal but was unsuccessful.

Maybe there are some configuration steps I need to follow?

The MP version is 1.3.11, Build 1.1.5426.22786.

This is the first time the HUD is visible in quite awhile.


Turns out that if I just scroll up to the top of the Mission Planner console window that appears alongside the main MP window, then the error messages go away and the HUD is displayed. Some sort of timing glitch perhaps? I am running on a Macbook Retina Pro with a fast SSD so maybe things happen too quickly?

I am attaching a png of the MP console window since I can’t seem to grab it any other way.

jsolderitsch - I have the same HUD issue with similar laptop and virtual machine, but also have an issue with the waypoint area not displaying correctly, see attached. All the fields are truncated. Changing resolutions makes it a bit better, but not much and every time I reboot XP the resolution goes back to what it likes natively, which is 1680x1050 at 60Hz. I can get the HUD back by selecting MP / config / GDI+ option, but I’ve read others having issues with that option. I’ve tried the Mac APM version and it looks okay, but at first glance it doesn’t have the capabilities the Win version has. I also tried Win 7, but I can’t seem to even update MP as it keeps timing out, argh!
Laptop config: Latest Macbook Pro (see attached pic) / OS X Yosemite / VM Ware Fusion V 7.1.0 / XP (all .Net updates) / MP 1.3.16 (everything is up to date)
So much for upgrading to OSX! If it works don’t fix it! Right? lol

The HUD displays for me now on start up when I choose GDI+(old type) in the CONFIG/TUNING section. No errors in the console then. Running Windows 7 Home Premium inside of VMware Fusion 7.1. Seems to work OK at this point for me. I was just offered the opportunity to upgrade MP and I am now running 1.3.16 build 1.1.5456.14788

I do my mission planning with DroidPlanner 2 so I have not seen issues with Waypoint drawing or resolution issues.

I just checked again and unless the GDI+(old type) setting is selected, I see the exceptions in the MP console and the HUD is not drawn.

Still running Mavericks as the native OS.

I forgot to add the pic

I looked at the Flight Plan part of MP just now and it looks OK.

I have my IRIS connected via USB.

Attaching a screenshot. The waypoint is off screen at the current resolution but it’s there.

But in the waypoint table I see that the column headers are truncated. I see of no way to make the table itself expand to have more column width available. You can mouse over some of the column headers and a little tool tip appears but it would be better to have MP use the full screen real estate for the waypoint table.


I also notice that if you have no waypoints defined yet then the waypoint table is extremely truncated and looks like the one in your screen shot. And there is no way to use the mouse to enlarge it.

I verified that loading waypoint files or creating a new mission opens up the fields enough. I don’t remember this occurring before, but no worries, it works! I can go back out and play! Yay! Thanks for your responses!