Mission planner or mini apm 3.1 problem?

just received my first mini apm board, i installed the mission planner and tried to see if i could figure it out. i can successfully do a accelerometer calibration but cant do a compass calibration, it always says that it does not have enough data points. i have tried fast, slow, jerky and smooth movements. also when i trie to install firmware ( first button on initial setup), it says that i cant load while connected to mavlink, then i will disconnect and then when i pick tricopter it will say unable to open com port: usbmodemfd131. right now this is one of the last parts in my first tricopter build and preventing me from flying. so what can I do?

any ideas?

Have you followed these ArduCopter Wiki instructions http://copter.ardupilot.com/wiki/initial-setup/ ?

We have followed your instructions and still have the same results while trying to load the firmware. The initial set up only gives one port option. When we select tricopter and then ok we still get: “unable to open COM port: usbmodemfd131”

We have down loaded all applicable apps and still are stuck. I’m sure its something painfully simple and would like some more suggestions. We are operating a Mac OS X Yosemite version 10.10.3 but that doesn’t mean we know how to work the darn thing.