Mission Planner on RPI Bullseye

I’ve just tried upgrading my RPI 4 GCS to the latest Raspbian OS. I did a fresh install of Raspbian, and a fresh install of MP based on the instructions here.. Now mission planner won’t boot up. The Mission Planner splash screen will come up, then it aborts.

I noticed two things:

  • in the new version of Raspian there is no option to turn off (or on) the OpenGL driver.
  • All the versions of Mono still refer Buster, not Bullseye. I have tried the latest nightly build but it didn’t help.

I don’t know if either of these make a difference but this isn’t anything I know too much about so it’s all I’ve got to start with.

If anyone has got MP working on the latest Raspbian OS, please let me know what you did.

I tried again after making sure all the updates are done. Still the same problem. Here’s the terminal text that came up while MP attempted to start up. Hopefully there is a clue in there for someone who know more about linux than I do.

Boot Abort.txt (49.9 KB)


It seems like the Raspberry Pi foundation has made a version of Buster available again on their website to simplify the switch back. Here’s the article.I guess Mission Planner wasn’t the only casualty of Bullseye. I had switched back before the article was posted but looks like that’s the fix for right now.

the issue is around certificates

so hard to know the root cause