Mission Planner on a Chromebook / Linux

I know very little about Linux, but would like to run Mission Planner on my Chromebook.

I was able to:

  1. Add the Linux development environment…
    How to enable Linux on your Chromebook (and why you should) | ZDNET

  2. Download Mission Planner for Linux…
    Releases · ArduPilot/apm_planner · GitHub

  3. Figure out how to run an appimage…
    How to Install AppImage Programs on Chromebook in 2020 | Beebom

  4. Got Mission planner to actually open and run…
    Eventually by double-clicking the appimage file

But now what… :slight_smile: When I click “connect”, I get “error opening port”. I’d like to connect via USB or more ideally, bluetooth (which I can with Windows).

I tried to get QGroundControl to run, but even when following the same install instructons as Mission Planner, QGC would not open on my Chromebook.


P.S. I was able to get Mission Planner for Android to run and even connect on the Chromebook, but it seemed slow and buggy and the window is quite small and hard to read, even in tablet mode.

I don’t know Chromebook but the Linux development environment is a virtual enviroment/machine. Usually needs to have passtrought for the host peripherals/devices you want working there. This may help Linux on Chromebook: This is how USB devices are recognized - Techzle

Thanks very much Rod. I tested several USB items I have laying around, some of them popped up in the box, with the question - do I want to use the device with Android or Linux? But some did not, and, the flight controllers I have on hand at the moment (Kakute F7 and an older Pixhawk (2.4.3?)) - sadly, did not either.

Oh well.

I wonder if I could connect via bluetooth or wifi?

Thanks again.

I’m not sure. As example I can use the BT of my FC in betaflight but I think it’s not supported in ardupilot. I’m new to ardupilot and not sure how is BT support for other FCs.
Never tried over network.

As for USB support in virtual machine that’s normal it seems, some will work other not. For ardupilot it creates a serial interface over the USB connection, so perhaps a matter of installing the correct drivers for the chipset on the FC.

Bluetooth and wifi DO work from a Windows computer to a flight controller via Mission Planner - I use that all the time - much more convenient than always having to connect a USB cable.

I’ve even FLOWN a short distance on bluetooth using bluetooth as the control link via my notebook and mission planner. Never tried wifi but the control link would go much farther - couple hundred meters? Not sure. Just have a good radio fail safe in place - RTL :slight_smile:

Maybe you know all this, but…

Ardupilot can use a “regular” R/C radio control link, or use telemetry radios, or use bluetooth or wifi as control links, and can even use all of them at the same time. And I’m sure I’m missing a couple others.

1 Like

I can see the FC BT listed in windows but cant connect to it. Same in android and it’s not listed if I open MP.
It would be really useful if I could connect it in android to start mag calibration in the field.

I think the hardware itself is OK as I can connect BT in the phone if using betaflight.

I wonder what I need to try connecting FC to phone with a USB cable. Probably a OTG cable?
My FC is SpeedyBeeF4 V3

Bluetooth should work, but yes
an otg cable connected with a usb cable to the flight controller should work - or also an otg cable connected to a telemetry radio (with of course a second telemetry radio connected to the flight controller).

Checked and the serial connected to BT wasn’t even set in the parameters. Adjusted for the right values but still no luck. Anyway It’s behaving strangely. It creates a bunch of ‘Standard serial over bluetooth link (COMx)’ when trying once to connect in windows. MP lists two of these COM ports but can’t connect to them.

I will keep trying.

I had tried running missionplanner in Linux, it wants you to install mono, but mono is buggy and annoying. Qgroundcontrol works fine, I download logs and set up things like geofence and flight plans in it.

Otherwise you can run apmplanner (kinda cousin to missionplanner, but it actually has a working Linux version).

Another way is get a vmware win7 environment and run missionplanner there (you’ll have to pass on the USB device for the flight controller to the virtual machine).