Mission planner not showing Q flight modes

Setting up a Q-Plane using Mission planner and Plane 4.2.1

On my desktop machine I see the Q-modes in the actions pane, on my laptop I don’t see those. Manual mode is also missing.

I have tried deleting mission planer and folders and re-installing the latest MSI but no luck.

Any idea where the modes have gone and how I get them back?

Try latest Beta version. This version shows them.

Qmodes

Latest beta has the same issue.

I can assign Q modes as per your screen shot but I can not use the quick menu to pick Q modes which is what my screen shot shows.

Rather odd!

Ah OK, this menu?

Yes exactly that menu.

The options I get are all for copter - I don’t get any plane options or Q options.

@tegwin Can you check Q_MAV_TYPE it should be set to 1 (FIXED_WING)
https://ardupilot.org/plane/docs/parameters.html#q-mav-type-mavlink-type-identifier