Mission Planner not showing beta and old fimware options

I’m running MP 1.3.31 and when I go to the initial setup / install firmware screen there is no option to download older or beta firmware. Any idea why? I want to try Copter 3.3. Not happy with 3.2.1. My previously stable asymetric quad is horrble to fly now after an autotune. Any help appreciated.

Solved…reloaded MP. All fine now.
However can someone tell me whether I should be using the traditional quad model or the asymetric model in the frame types. My frame is a custom asymetric 550mm.
Is the ‘V’ model specifically for the Iris frame?
I previously used the traditional quad model as the setup on my APM 2.6, which worked fine.
Maybe on the Pixhawk it would be different…
Best. DP

Don’t know how similar it is to your frame, but I fly a TBS Discovery as a ‘V’ frame on 3.2.1 and it flies perfectly after an autotune. That’s with an APM and a Pixhawk.

Hi Mark, I’ll try the assymetric model and see what happens.
My setup didn’t like 3.2.1 at all especially on the APM 2.6. On the Pixhawk I nearly had a nasty crash after a 3.2.1 autotune when the voice on Tower informed that the compass wasn’t calibrated all of a sudden.
Very odd. So I’m going to try 3.3.1 beta…I’ll report! Best DP