Mission Planner not connecting to PH2 by RFD900x

Hi guys,

I have been trying to get mission planner to connect to the Pixhawk2 by RFD900x serial connection.

I have successfully connected the modems, the status LEDs are both green. I have also updated the firmware to 2.55 from the RFD firmware site. I have used default settings for the radio modems except for NetID that I have changed to 92. I have also tested on NetID 25.

My Modem settings are in this screenshot

I have also tried various serial settings

I have tried both MAVLINK 1 and MAVLINK 2 on the serial port.
My RFD900 radio is connected to Serial 1
I have a little banggood esp8266 WiFi radio that is working on Serial 2 the PC connects to the TCP address and mission planner connects.

I have also tried QGroundControl and APMPlanner with same results.

Any help is appreciated, thanks.

try disabling rts/cts as a test

Hi Michael, Thanks for the idea. I have tried but no change.

I’m beginning to think it might be something with the FTDI driver? How might I test that?

The FTDI device is correctly loading the radio settings so it is probably not at fault. I’d try setting the the SERIAL1_PROTOCOL to MAVLink 1 as a quick test, and also check that with just the aircraft side on the RFD LED is indicating that data is being sent to it.

  1. Mavlink1 no change
  2. No RED LED for data transmission on either side.

I had to solder up an extension lead and wing connector, maybe I have my TX and RX around the the wrong way?

Yeah verifying the TX/RX swap would be my first guess. You could also use jumpers from your FTDI cable to check that your extension/connector is correct, as you should be able to use the FTDI cable through the telemetry port.

Ok I belled out all my conductors with a multimeter to check both point to point and insulation resistance between conductors.

I found a 7Mohm resistance between earth and TX out from the PH2.

I checked my connector terminals at the wing connector visually and couldn’t see anything obvious. I then sprayed the connector with contact cleaner and the 7Mohm short has gone.

Testing connection still failed. I then moved the WiFi on to Telem 1 and WiFi does not connect on Telem 1, WiFi does work on Telem 2.

Tested RFD900 on Telem 2 and it trips the over current protection on Telem 2. So I’ll have to put in a BEC to supply the RFD900 on Telem 2 for more testing.

I suspect my Cube carrier board has a damaged TX out line? Does this go straight into the Cube or is it the Carrier board that is probably damaged?

Ok no damage to the board. phew!
I have reinstalled arduplane 3.8 back to standard parameters. The RFD is now working so its a parameter thing.

Now I just need to step through resetting my params until the RFD drops out.

Hi @Duds, did you ever get the parameter figured out?

Hi, We are facing the same error on RFD900x, they connect with each other and I am also able to connect and update firmware using RFD Tool and even Mission planner (SiK Radio). Used multiple SiK version but there is no response.