Mission Planner loading problem

I am new to ArduPilot but it all seems to be very established with loads of support , software etc.

I downloaded the latest Mission Planner and then tried to install it following the guidance provided, then the following was shown on the screen.

“This application requires .NET Framework 4.0. Please install .NET Framework then run the installer again”

Has anyone else encountered this problem, I have never heard of or used .NET Framework.

The operating system on my PC is Windows 7 Professional 32 bit.

Have I missed something in he instruction?


Try going here and downloading. I think this is the correct version.


Hi Joe,
many thanks for your reply, I’ll give it a try tonight and let you know how I get on.


@signalman341 I have moved your post from the Blog area to the Mission Planner category where it is more appropriate.

When posting please consider the correct area so more people will benefit from your post and be able to help.

Thanks Mike, still finding my way around.


Hi Joe,
all sorted, problem solved, thanks for your support it is most appreciated.


Your welcome. Glad you got it all sorted.
Have fun.