Mission planner language

Hello everyone,
I will need some help to change the language in mission planner . My computer setting are in italian. I install MP and i change the language in the planner window in italian but I don’t like it because the pronunciation of the English words sounds weird. So i go back to English and now the words are good in English but numbers and the accent is still in italian.
I try everything, change all my pc settings in English, deleted and install mp again, delete one more time everything and use cclener to cancel all the folder but nothing.
Everytime same story. I saw in other posts that you can force the languages.
Here is A short video

Someone can help me ?

In config/tuning page did you choose English as UI language?

Yes, many times.i also cancel Mp , delete all folders, turn all my computer settings in english and install again mp hoping that will start talking in English,but nothing!
Seems that I can’t delete all mp files from my computer because every time when I reinstall it all settings are the same like before cancel it.

I hope I read that there are other things that we have to erase to complete erase MP but not remember now, If I find I share with you, perhaps someone else can help

change your windows speech settings

Thank you Michael for you answer . If you see my frist post i try everything. I delete everything, erase all folders , change all settings in English (everywhere) and reinstall MP but nothing. In MP i have same settings like before uninstall it.

SOLVED!!! go to this folder in Windows 10:


And select the speech you want.

Info source: