Mission planner install firmware issue

Hello all, i keep getting this issue with the latest install of MP 1.3.71. I have uninstalled and then reinstalled and i keep having this issue. I have reported the issue.
Details: I am trying to upgrade a quadcopter with ardupilot 3.6.5 and this error ussually appears. It also happens if i run it as admin.
autopilot: Cube black Pre-2019, with here gps.
computer: Lenovo legion y530,

Microsoft Windows 10 Home
Version 10.0.18363 Build 18363

Have you tried upgrading to the latest mission planner beta

Yes it is the latest update. However I was able to make it work with the “install firmware legacy” option.

IOW “Installed firmware old” :smiley:

this error is because of a bad update/a dll failed to update correctly.

please try updating again, and i think it will fix itself.

or install from the msi.

I uninstalled mission planner, then reinstalled from the MSI that i downloaded today. Then i restarted the computer and tried to update using the non legacy version of Install firmware and got an error still.

how uptodate is your windows install. mainly .net?

Is this what you are asking for?

please try manually delete all the files in the MP directory, and install from msi.

the cause of the issue is a file not updating, or some other file is left over.

1 Like

Just to confirm this error on Win7 using the new ‘Install Firmware’ from the first appearance of it.
I have been using the ‘Install Firmware Legacy’ without issue.
Latest version of MP updated this morning.

I will check windows 7. Hadn’t got that clue untill now

Uninstalled, then deleted mission planner folders in documents, program data, program files (x86) and then installed from msi. That seems to have fixed the issue. Thank you!