Mission Planner in Ubuntu Stuck on "Done" Screen After Connection

Hey All,

I have MP running in Mono on Ubunutu 20.04 - but am running into a issue.

I have a simulator running for this test - but I don’t think that is causing my issue.

After connecting to the aircraft, I successfully get all parameters but then the “Done” dialog box does not go away. Thus, I can not interact with MP. Data in the background shows full connection and updating well. Any thoughts?

could you please send a screen shot of terminal window

Everything looks normal

Did you tried this ?

Also check your link with other gcs like apm planner or qgc

Yes - I followed those instructions.

Works perfectly with QGC.

Mission Planner is working perfectly in the background too - I can observe by sending mavlink commands and see the GUI updating properly. The “Done” window just doesn’t go away and removes my ability to interact with MP.

Try with older version

Rolled back to latest stable and still stuck on Done.

I can now confirm that this only happens when connecting to an SITL setup via the following steps:


EDIT: It seems like connecting to an actual aircraft has made the SITL connection part work too now sometimes. If I connect to an actual aircraft, disconnect, then connect to the simulator.

It looks like connecting to the sim opens up two windows sometimes which is where the issue arises:

Is there anyway to make it so that MP doesn’t autoconnect to TCP/UDP ports? I believe this is where my issue stems.

I don’t think there is an option to disable auto connect for udp but you can redirect udp to a virtual serial port with mavproxy


I played around with this a bit more and I think I have narrowed down the issue to the exact problem.

When I boot the SITL it automatically sends out data on two streams and When MP is open it tries to connect to both streams instantaneously and then hangs on “Done” for some reason.

If I run the simulator and restrict it to only streaming out at one address MP works properly. However, as soon as I start outputting data on a second stream MP tries to connect (even though it is already connected to stream 1) and then gets stuck on “Done” again.

I do need to have two data streams being outputted via mavproxy - so I will have to find a fix eventually.

Any input is greatly appreciated!

Right now my best bet has been to spam cancel as soon as MP starts automatically connecting to both IPs and then manually connect normally. Not ideal - but functional till I figure out the bug.

This doesn’t work 100% of the time though - I run into very slow parameter loading sometimes followed by a “Failed to Connect”.

This might help to configure different streams in different ways


do you not get a X in the corner?


I can confirm that there is no any close button with ubuntu 20.04 latest gnome version

No X on my end as well.

I am facing the same problem; seems to be a problem with UBUNTU 20 ( not sure though as the same works like a charm with UBUNTU - 18). I am ON it will update if i find a work around.

To close the stucked window right click on it in taskbar and close it