Servers by jDrones

MIssion Planner hangs on loosing connection

My Mission Planner 1.3.58 (on Windows10 64bit) continually hangs when the Mavlink connection is broken. The hanging does not restore itself and forces me to manually close it in the task manager.

My typical workflow uses a DragonLink with bluetooth connection. The connection break that triggers the hang is not the bluetooth link but when the aircraft goes out of signal. This also happens when using a standard 3DR radio (USB) with another aircraft.

Has anyone a hint for me what might be wrong? Having to reconnect while inflight and re-download the parameters is a killer.

I’ve never seen this happen before can you please provide a tlog. As mission planner should run fine without getting any data.

Ill need to replicate it again as those logs have been deleted.
Touch wood, it hasn’t happened recently.
Thanks for checking up on this, though.

I have actually also verified this, both with the DragonLink BT and with WiFi (WTR24) on P9 telemetry radios. I have had it wipe the parameters out and reset back to defaults using a force-kill when it hangs on a wireless connection.

I actually sent @tridge the rlog and tlog from a “hang” to see if we can figure out why it is hanging in the first place.

Also should duly note - it does not do this running MP on Linux. I have only had the problem running it on Windows.

@Michael_Oborne here is the link of the rlog and tlog I had sent to tridge, if you want to take a look
https://drive.google.com/open?id=1lEbWDgYpN7O8Y3U5mpkFnpSCghGmtpi-

In this case I was connected via WiFi with P9 radios with WiFi dongle on them. Was connected with QGC on a Android tablet without issues. Can connect simultaneously with MP on Linux with no problems. But on Windows it hangs and crashes the telemetry link and even causes the Android tablet to disconnect.

I experimented with it quite a bit and am convinced it has something to do with “Windows Defender” either blocking ports at random, or possibly a weak network stack in Windows causing it to crash. When it works fine on Linux, same build of Mission Planner, I can’t see it being a problem in the MP code.

@Michael_Oborne here is my log. I managed to replicate the issue today.


Running Arduplane3.9.2 with latest Mission Planner on a up to date Windows 10 64bit laptop. The Telemetry is running on a Dragonlink bluetooth connection.
I think it has something to do with a bad or low bluetooth connection. I see it happened right as the controller moved away a bit from the laptop.

this is a Bluetooth issue. MP unfortunately cant protect against this, as its windows causing the hang to the unstable Bluetooth device.

1 Like

Seems like this is still a problem in the latest release? I am not buying the explanation that it is a BT problem, other apps like QGround using the same link does not do this. I like Mission planner but this is a deal-breaker for me :cry:

I replaced all BT radios with ESP8266 WiFi radios some years ago. I just flashed these yesterday ready for the next builds. $2.50 ea

Works on Mission Planner Android.

1 Like

yes i would use a esp over bluetooth anyday

Yes, WiFi is great but the problem of Mission planner freezing has nothing to do with BT, it freezes with WiFi and dedicated telemetry radios as well. It only happens with the Windows version of Mission planner.

what do you mean by windows version?

The binary that runs on windows. Actually not sure if there are others, did see an Android folder under the downloads and I know it can be run under emulation on Linux.
I tried APM planner today on the same plane and computer, it still disconnects (now confirmed to be a TBS BT issue hopefully fixed by the latest beta firmware) BUT APM planner does not freeze.

Edit: It is also possible to get MP to freeze if you try to connect, by mistake, using a COM port that does not actually have Mavlink running on it, this depends on what is actually running on the port I suppose.

I am having a similar issue. MP locks up and I have to kill it with the take manager. I am using a dragon link v3 slim bluetooth connection with my plane and radio sitting on the bench. I thought I wired my setup wrong but I tried it with QGC and I can connect to my plane.

i fixed something like this just the other day but is only in beta mission planner.

Hi Michael,
as I am experiencing similar issues of Mission Planner regularly - which is very annoying during flight -, I wonder if there is any solution available.

via what connection method?

Hi Michael,
thanks for the quick reply. I am connecting the GCS via bluetooth with the radio transceiver.

agh, my guess its bluetooth is playing up. this is one thing i cannot fix. as the hang occurs at the windows/kernel/bluetooth driver level

Okay, thanks for the analysis. Another interesting observation is that although I configured the baudrate at 115000, if I choose “auto” in the connect section, it selects much lower baudrates (9600). I see the similar behavior when connecting via USB. Is there a reason for that? I mean, USB can transfer at much higher speeds than that…

Servers by jDrones