Mission Planner GPS

I am trying to connect to Mission planner and GPS but here GPS signals in not present. How to fix it?

How many GPS’s you have? If one, put its parameters at GPS1, and GPS2 as none (simplest procedure).

Can you describe it in detail? I have attached a primary GPS, that is connected to Pixhawk and a servo-grade GSNN Antenna also attached.

Full Parameter List of Copter → your version

GPS Parameters → GPS_TYPE2=0, but copy other parameters to those for GPS1 (No Fix above). Start with GPS_TYPE=1 (auto).

For your serial port SERIALx_PROTOCOL=5 (probably correct (No Fix above)).

All above supposing you have one GPS.


I am still facing “hdop” and “sats” issue. Also, I tried to apply your suggestion and later it is not even showing “3D Fix” if it is in outside.