Mission Planner freezing and crashing

Recently I bought three zed-f9p modules to get gps for yaw and precise positioning, and after setting everything up, when I try to connect to mission planner via Usb or telemetry, it just freezes and crashes during an attempt of connection.

Only the rover is connected to my cube black, and when I unplug it, I can connect, but as soon I plug back again, it just freezes and crashes

It has the 4.1 dev firmware in cube, and I am using the latest beta in mission planner

This is a long shot, but maybe try 4.1 beta 3 or 4 (just came out) instead of dev. When I have had MP crash it was when I did NOT have the latest beta of MP, but you have that.

I tried that, but also didn’t work.

What I noticed is that happens only when the pvt message is enabled from rover, as soon as it is enabled, the mission planner crashes

But is a necessary message for gps yaw and to get rtk fix so can’t disable

I am at a loss, but one thought:
I don’t know how much this will help with the entire process but it might be a good feeling to see if it works with the stable 4.1 release (not Yaw, of course, but just RTK). You can just set up the 2 GPSes as standard GPSes (parameter values 17 and 18 are not in that release).

tried, also didn’t work

Extremely strange. Stable release with 2 GPSes should work all day. Just fir grins, if you upload your parameters, I’ll load them in my cube and see what happens. I know we don’t have the same connection scheme but it won’t hurt. Up to you.

And maybe someone else will come along in the meantime with an answer.

Parameters.param (16.3 KB)

I loaded the parameters into my Cube Orange running Ardurover 4.1-beta3 and there were no problems. I shutdown the Cube and brought it back up and, as expected, there were no GPSes since you have GPS_AUTO_CONFG=0. I changed that to 1 and the GPSes immediately went to RTK FIXED.

I don’t have time right now to load the DEV version. I don’t know if this helped much.

For what it’s worth, I am running MP build 1.3.7824.3427 and I am running the beta3 except that I changed the baud rate setup for UART2 on the 2 GPSes to 115200 by modifying the code and compiling. That shouldn’t matter, but for the record, that’s it.

@GRS26, This post from @Yuri_Rage could help: Rover-4.1.0-beta4 released for beta testing - ArduRover / Rover 4.1 - ArduPilot Discourse