Mission Planner forward MAVLink packets over UDP link

I have Mission Planner connected via a serial radio link to an APM. I want Mission Planner
to forward the MAVLink packets received from the APM over a UDP link to another computer(Raspberry Pi).
Is this possible? Are the packets forwarded in a transparent manner or does Mission Planner alter them in any way?

It is possible to mirror Mavlink packets in MP, press ctrl+f and press Mavlink. Enter type of the connection and ip/port. You can check if MP should allow access to drone or not.

Hey Nikita, thanks for response. I never could get that to work. Sorta got it to work using APM Planner.
In Mission Planner tried to forward packets to a RPi running MAVProxy (I know typically direction is from MAVProxy to Mission Planner) using both UDP Client and UDP host. Computers were connected with a crossover cable. I could ping both ways.
Mission Planner IP = 192.168.1.10
MAVProxy IP = 192.168.1.11

Start MAVProxy with: sudo python mavproxy.py --master=UDPOUT:192.168.1.10:14550

says waiting for heartbeat from 192.168.1.10

In Mission Planner try to connect using UDP host nothing happens
try using UDP client nothing happens. I tried about every other combination of command on the MAVProxy as well,
never had any luck. Im sure I am just missing something.
If anyone knows the definitive way to do this I would appreciate it if you would share it
with me, if it is possible at all.

Thanks again!
Bill

ill look into this, as I believe it should work

Thank you Michael. Thanks for all the work you do, thanks for the time you spend, and thanks for sharing with the rest of us!

is there any chance of getting a wireshark log?

I did a basic test and it worked fine for me.

Hi Michael, I went in a different direction. I have a ULRS on a mast with a RS 485 link down to Mission Planner. Instead of passing MAVLink packets from Mission Planner to a Raspberry Pi I just put the RPi on the 485 bus as well. It is just a “listener”, running a modified version of MAVProxy. Also have a minimOSD on the 485 bus so performing OSD function on the ground instead of air.

If I have some time I will revisit the packet forwarding problem I was having, Im sure I was just making a boneheaded mistake. Thanks for checking this out, take care!

I am trying three MP instances (1580, 8492, 11376) on one laptop (192.168.137.150) connected to three drones (192.168.137.151/2/3), each MP instance forwarding to another laptop (192.168.137.154). On this second laptop I connect using a connection list:
udp://localhost:14552
udp://localhost:14556
udp://localhost:14564

It works:


(LiveTcpUdpWatch capture).

Bytes received from the drones and sent to the second laptop evolve moreless the same.

But if in order to not need the second laptop, I forward to the same laptop doing the same connection procedures substituting 192.168.137.154 with localhost (and adding 20 to the ports used 14572/14576/14584 when forwarding and in the connection list in a fourth MP instance), this doesn’t work and does not show in LiveTcpUdpWatch.

Should this work (forward MAVLink to localhost)?
If so, what can I do doing wrong?

It should work could be a windows issue however. I can’t really say too much on this one however

On MP 1.3.68.1 build 1.3.7236.10299 tcp redirection lo localhost works:
MP_UDP3_TCPlocalhost_4MP

Very nice.