Servers by jDrones

Mission Planner Flight Modes not displaying in configurations or HUD

I am setting up a new fixed wing build using Mission Planner 1.3.74. I installed ArduPlane V4.0.9 on a Pixracer R15.

During setup, when attempting to set the flight modes in “Setup > Mandatory Hardware > Flight Modes” or “Config > Flight Modes”, the drop down menus only have the option “INITIALISING”.

NoFlightModesinDropDown
I also tried setting the flight modes directly in the “Full Parameter List” and then writing the new parameters. The parameters saved and show up when I cycle power. However, when I go to the HUD, the flight mode is listed as “UNKNOWN”.


I can use my transmitter to toggle the highlighted flight mode under the setup tab, but I have no idea which flight mode it’s registering.

I have tried “param gen” as suggested on other posts. I also tried uninstalling and reinstalling MP. Neither of these solutions fixed the problem.

Has anyone had this same issue? Does anyone have any suggestions? I don’t want to test fly without knowing the flight mode.

Update: I updated to the most recent BETA version (1.3.74.1) and the issue was resolved.

Another Update: I thought everything was working and now I am experiencing the same issue again. Things I’ve done since it was working:

  • Set “SERVO1_FUNCTION” = 77 and "SERVO2_FUNCTION = 78 to set up as a flying wing
  • Calibrated LEVEL
  • Calibrated ESCs

When I reconnected after calibrating the ESCs, the flight mode on the HUD displayed as “Unknown”. I checked the configuration tab and again only “INITIALISING” is listed under the flight mode drop downs. I tried “param gen” and that didn’t work. Any thoughts?

Having the same issue. I deleted the mission planner folder from the my documents folder and reinstalled MP. This fixed it for a few days but the issue is back.

Update: I set the flight modes directly using the full parameter list. I have been able to successfully fly in the set modes (Manual, FBWA, RTL), but the mode still displays as “Unknown” on the HUD. This leads me to believe it’s a bug in Mission Planner because the flight controller knows which mode I am setting with my transmitter.

Same here. The modes return if I delete the mission planner folder from the my documents folder. You have to reset the presets and joysticks files(if you use one).

Not sure how long this fix lasts.

Servers by jDrones