Mission Planner doesn't work with NMEA output

Hi everyone,
I recently got a NEO-M8N GPS and a Pixhawk, and I was trying for the past few days to configure the GPS to output NMEA messages and have it working in Mission Planner. I connected the Pixhawk to MP and used a passthrough to read the NMEA messages in u-center, and so far so good.
However, I encountered two issues that I cannot figure out:

  1. For some reason MP only works if I set the output to UBX. As soon as I switch to NMEA it stops updating. I set GPS_TYPE=5, and I also tried setting SERIAL3_PROTOCOL=20 for NMEA output (even though I’m not sure I need to do that), but still nothing.

  2. Every time I disconnect and reconnect the Pixhawk to the PC, the output goes back from NMEA to UBX. I suspect Ardupilot is doing that, but I’m afraid my C++ knowledge is pretty limited, so I don’t know where too look in the source code. If anyone can help or at least point me in the right direction I would very appreciate it.

Thank you in advance!

Hello @AcesOrion

Probably your GPS is being autoconfigured by the ardupilot software.

Try setting GPS_AUTO_CONFIG param to zero and check if the behaviour changes.

Worked like a charm, thank you very much!

1 Like

Nice man! Glad to know about it!