Mission Planner doesn't let me upload beta versions anymore

Hi, after what time I made an update to the beta version today I tried to check if new beta versions were released but it does not allow me to update anymore and gives me this warning.
Someone can tell me why.
Thank you

I have same problem for last few days

Hi Martin,
so no i’m the only one … weekly i check if there are beta versions and up to the last few weeks no problem loading them … this week i tried to check but as soon as it starts it gives me this error and do not allow me to proceed further.
I hope this problem can be solved.

1 Like

I’m a complete noob when it comes to GitHub so take this with a grain of salt, but I just looked and the last Beta DotNet build versions of Mission Planner failed. I don’t know exactly what that means, but I"m going to guess that’s why you can’t update to the latest beta. I’ll guess the devs are on it and it will be back up shortly. If you need a more recent beta you could probably go to GitHub and download it manually.

1 Like

Yea Michael will have it sorted for us soon I would think

im aware of this, appveyor decided to put caps on downloads with 1 days notice.

if your version does update, it will work just fine, but it caps out at 1024mb per day.

the new beta will download from github releases instead

1 Like

ok appveyor just increased my cap from 1gb a day to 10gb. so it should help to fix the issue, but i think some will still hit the issue

on a side note, thanks everyone here for using the beta. catching bugs before release does help alot.


Who gives me the direct link to download the latest beta from github.
I tried again to do it through mission Planner but it always gives me that error reported at the beginning of my post
Thank you

Continues during past several hours.

once that error comes up, it would be 24 hours before it works again

If it doesn’t let you download you may need to set up an account. Pick the latest action you want (DotNet for windows or Linux), and download the Artifact.

1 Like

When I update Mission Planner I see a new build number. Today it’s 1.3.8062.38682. Is there any way to cross reference that back to anything on GitHub? Such as Build #1432?

I’ve downloaded a fresh MP install, checked DNS and internet connection, time settings…
I’m still getting Forbidden for Beta Updates

And a bunch of errors for ordinary updates

Yet to install the complete Beta download from the link above

I unzipped the full Beta download from the link provided, extracted it and replaced all the existing files.
It shows as this version, 1.3.76 build 1.3.8063.11439

The the normal Update button produces the expected “No update available” message
And the Beta Update button produced a small download and install process that seemed to work OK but didnt produce any change to the version or build numbers.

The issue is that a standard install that’s been regularly updated was unable to update any further without the manual intervention, for me at least.

The last digits translate to a date and time, and is what’s in version.txt. Ie. https://github.com/ArduPilot/MissionPlanner/releases/download/betarelease/version.txt

Beta versions use to come from appveyor, but after the bandwidth limit introduction, this is now moved to github. The catch is that all older beta users need to get the updated files to point to the new GitHub Location. I believe this will slowly resolve itself, but once you get the error message, it could be 24 hours before it will work again. Mp will use the part files it did successfully get though, and not download those files again, and when it does work, it could be a back to back beta update, as I’ve stopped new builds provided by appveyor

Confirmed this method (zip file download + file replacement) also worked for me after receiving the same, related errors.