Mission planner does not connect to PH2.1

New PH2.1 will not connect to Mission Planner. PC with Win 8. Restarted Computer, instal and remove Mission Planner twice. Did try different usb ports, COM6, works with other applications.Using both Wizard and initial setup, but nothing works :frowning:
Message, No Heartbeat! or No response from board.

You haven’t mentioned what firmware you have loaded?

Or are you trying to load firmware?
In which case the “No Heartbeat” message is as expected if you try to connect to a bare board.

Have you allowed the drives for the board to load?
In the Mission Planner Com port list it should see and identify the board.
Does it?
Have you verified this in Device Manager?

Hi Mike.

Thanks for your mail.
Did try both X8 and Rover.

How do I allow the drives for the board to load?
Mac user since 25 years

When board pluged in, only Com port in MP is COM6
If I plug in the Cube i get PX4 FMU (COM7)

Best regards.


The answer is in your post.

So the com port needs to be set to 7
Have you tried using Auto?

Where do you see PX4 FMU (COM7) that you indicated?

Only se COM port PX4 FMU in mission planner when Cube is connected.

The PX4 that shows up in your COM port 7 is the Pixhawk 2.1

Connect to it.

And then enjoy! :slight_smile:

But this is when I connect to the Cube, using the port on the left side of the PH 2.1.
Should I not be using a port on the right side for upploading FW ??

yea you should use the com port on the cute, instead of the one on the carrier board.

Thanks everyone for your support :slight_smile:

That is great! Would you mind putting a solved sign in front of your topic title, so that community members will be able to refer to this post for similar issues they face? :slight_smile: