Mission Planner display issues

Hello all
I have been having some issues with the latest version of mission planner 1.3.41 not displaying on the screen correctly.
This only occurs once I have connected my UAV to the computer (via mavlink or direct connection) once i disconnect the uav the display remains incorrectly displayed, if I restart mission planner it rectifies the issue until i connect to the uav again.
The greatest issue is that i cannot see all the data displayed on my screen including direct commands - very important once I’m flying.
Can anyone please help me with this issue or will this be rectified in the next update.

Screen shots of issue:


I fixed my issue by running mission planner in compatibility mode windows 8. I was having the same kind of issue.

Thanks Johathan.
Now I just need to figure out how to run in compatability mode windows 8.


right click your icon then click properties and then click the compatibility tab then select windows 8 or whatever works for you. also you might check the box that disables display scaling for high DPI devices.
Just some proof that it solved the issue for me.


Unfortunately this hasn’t fixed the problem. Screen is still not displaying correctly.

Anymore suggestions?